5

I can play audio to analog jack output with mplayer and aplay, but i cannot get it working with omxplayer.

# setup audio output
modprobe snd_bcm2835
amixer cset numid=3 1

# This is working
mplayer -vo fbdev big_buck_bunny_720p_surround.avi

# This is not working (video ok, no audio)
omxplayer big_buck_bunny_720p_surround.avi

# Even this is not working
omxplayer -o local big_buck_bunny_720p_surround.avi

omxplayer's output:

Video codec omx-mpeg4 width 1280 height 720 profile 0 fps 24.000000
Audio codec ac3 channels 6 samplerate 48000 bitspersample 16
Subtitle count: 0, state: off, index: 1, delay: 0

Video is playing, but without audio. Pulse isn't installed.

  • With a fresh raspbian it works. It seems something related to kernel, because I've recompiled the kernel, same version and same configuration with some modules added. – Alessandro Pezzato May 31 '13 at 7:47
  • I have the opposite problem, only omxplayer works, aplay doesn't. – mcandre Dec 21 '14 at 2:39
5

I had the same problem and I found a solution.
You have to put your GPU memory at a reasonable level.

In the file /boot/config.txt,
add the line gpu_mem=128

From Steven Hickson:
"Also make sure your gpu_mem split is at a reasonable level such as 128/128 by adding the line gpu_mem=128 in the /boot/config.txt file in the newer firmware versions."

Source: http://stevenhickson.blogspot.se/2012/08/setting-up-omxplayer-gui-on-raspberry-pi.html

2

You may need to force HDMI output with the following command:

omxplayer -o hdmi x.avi

Worked with Raspberry Pi 3, Raspbian GNU/Linux 9 (Stretch), Bluetooth audio device.

  • Gollum, do you mean to use alsa or hdmi as the audio output device? – Greenonline Apr 13 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.