0

Update

The below is for Raspbian Jessie and does not work for Stretch

Any help on how to go about getting bluetooth to work with Stretch would be appreciated...

Original question

I am new to Pi and been trying to get bluetooth speakers up and running with no joy.

I followed this article step by step - https://www.raspberrypi.org/magpi/bluet ... erry-pi-3/:

In short that is:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install pi-bluetooth blueman
sudo apt-get install pulseaudio pavucontrol pulseaudio-module-bluetooth

Result is no audio at all via bluetooth, HDMI or jack. I have tried with three devices and result as follows:

Bose Soundlink Mini:

I can connect and pair via "bluetooth manager" but device does not show up in pulseAudio GUI.

Zoro II Wireless Headphones

Connect and pairs ok with "bluetooth manager", shows up in pulseAudio GUI. Can select as output device in Chromium. But no sound plays through headset. I tried muting built in and selecting headset as fall back but no joy.

In this case I can see audio registering on the built in output via the PulseAudio GUI.

Mpow Swift Bluetooth 4.0 Wireless Earphones

Cannot be detected by "bluetooth manager" at all.

I then tried to switch to builtin jack socket using:

sudo raspi-config

Then selecting advanced > audio > "3.5mm jack".

Still no output via two different sets of working headphones.

I have tried using sound sources on Chromium, a terminal speak test or 4 and an MP4 via VLC.

Finally as Raspbian was already installed on the sd for some reason when it arrived I tried a fresh install and repeated all steps to the same result. I also tried using a spare Pi in case of hardware issues with no joy.

Any help would be great.

  • if you're on stretch do not follow that guide. I am having the same issues as you. The problem is actually the raspbian os. You will only get bluetooth on browsers, I am able to get youtube working on bluetooth but not local music files using clementine. You need to remove all the packages that you installed exept pi-bluetooth. – answerSeeker Jan 14 '18 at 7:26
1

I feel your pain, I have the same setup and trying to troubleshoot at the moment looking for a solution.

edit: I've tried a bunch of things.

I just did

pi@raspberrypi:~ $ sudo killall bluealsa
pi@raspberrypi:~ $ sudo bluealsa --disable-hfp

then i was able to play a wav that i downloaded

aplay piano.wav

audio started playing, and i was even able to watch youtube videos.

  • Alex, in future please do not post as if this were a running thread on a discussion forum -- this is not a discussion forum, it is a question and answer format (if you had taken the tour initially, you would know this). Although what's here is fine as an answer now, the original version, which was just, "I feel your pain, I have the same setup and trying to troubleshoot at the moment looking for a solution," is not an answer, and it is exactly the sort of pointless dialog this format is meant to discourage. – goldilocks Jan 14 '18 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.