1

I'm new with RPi and also Linux, so my question might be stupid but I tried to get Python 3.6 running with different ways (compiling, pyenv, berryconda). In general I think python is running on all versions but most of the "standard" modules not. I assume it has something to do with the PYTHONPATH, but I'm not sure and don't know how to fix it. I'm getting always this kind of failures:

(3point6) pi@raspi:~ $ python -m fauxmo.cli -c config.json -vvv
Traceback (most recent call last):
  File "/home/pi/berryconda3/envs/3point6/lib/python3.6/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/home/pi/berryconda3/envs/3point6/lib/python3.6/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/home/pi/berryconda3/envs/3point6/lib/python3.6/site-packages/fauxmo/cli.py", line 10, in <module>
    from fauxmo.fauxmo import main
  File "/home/pi/berryconda3/envs/3point6/lib/python3.6/site-packages/fauxmo/fauxmo.py", line 15, in <module>
    from test.support import find_unused_port
ModuleNotFoundError: No module named 'test'

here is a list of install modules:

(3point6) pi@raspi:~ $ conda list
# packages in environment at /home/pi/berryconda3/envs/3point6:
#
ca-certificates           2017.7.27.1                   0
certifi                   2017.11.5        py36h3c44272_0
dev                       0.4.0                     <pip>
fauxmo                    0.4.5                     <pip>
ncurses                   5.9                           0
openssl                   1.0.2l                        0
pip                       9.0.1                    py36_0
python                    3.6.3                hea4cac4_0
readline                  6.3                           0
RPi.GPIO                  0.6.3                     <pip>
setuptools                38.2.3           py36h2883f55_0
sqlite                    3.15.0                        0
tk                        8.6.6                         0
update                    0.4.4                     <pip>
wheel                     0.30.0           py36h76583d5_0
xz                        5.2.2                         0
zlib                      1.2.11                        0

Has anyone a good (and easy) idea how to solve it?

0

Is it necessary for you to take conda? Because python2 and python3 are preinstalled on the raspberry pi:

Test commands:

python

output:

pi@raspberrypi:~ $ python
Python 2.7.9 (default, Sep 17 2016, 20:26:04)
[GCC 4.9.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

and command:

python3

output:

pi@raspberrypi:~ $ python3
Python 3.4.2 (default, Oct 19 2014, 13:31:11)
[GCC 4.9.1] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>

on newer versions, i think python3.6 is preinstalled.

so you can install new packages for python2 with command:

pip install "your_package"

and with python3:

pip3 install "your_package"
  • Thanks for your recomendation. Basically it is not necessary to take conda, but one module I need, needs python 3.6.3. As I mentioned I tried to compile it and in general it worked, but with the same problem of missing modules. – luks29 Jan 6 '18 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.