1

I have a RPi 3 that's running Libreelec and up until two days ago, it never had an issue appearing in MS Explorer under Network and Homegroup. It is connected to the Wi-Fi and I can actually see/transfer files to the Pi from my computer using a tool like Advanced IP Scanner, which opens in an explorer window using the IP address.

Why doesn't Windows recognize the Pi as a networked device? I did a search of my internet history to make sure I didn't do anything to alter the network or the Pi, but it looks like the only thing I did was connect a new Steam Link.

How can I make the Pi visible again?

0

Windows doesn't have the same file system as rasbian/linux. So You have to mount a samba server See the tutorial here: RPI-Win

  • I don't think (lack of) Samba is the issue, as the first paragraph suggests samba is running on the Pi (I can actually see/transfer files to the Pi from my computer) - the issue is visibility of the Pi in microsoft windows "network" section in Explorer – Jaromanda X Jan 9 '18 at 0:32
0

You need mDNS service(s) running. It’s called various things; bonjour, rendezvous, whatever. Try running netstat -tnlp as root, and see if port 5353/udp is open. It’s multicast-DNS for discovery and identification of resources on the local network. Samba should be able to handle it, but if it doesn’t, use apt search mdns and see what you can work with. Of course, look for mDNS related settings in /etc/samba/ ...

Since it has worked, you either changed something, or (equally likely) the service has just stopped working. Perhaps after an update, perhaps for no apparent reason. Check in /etc for relevant configurations, see the output of systemctl —status-all (IIRC).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.