2

My problem is that I can’t view the uv4l video stream from the picamera in my PC’s web browser.

My setup is: Raspberry Pi 3 - running Jessie - wireless connection to router. PC - running Windows 10 - Chrome browser - wired connection to router.

I wanted to add a camera to the front of a MonkMakes robot vehicle (controlled by the headless RPi) which would have minimum latency when streamed. According to the literature the installation of uv4l would achieve this.

I installed uv4l using the guide at http://www.linux-projects.org/uv4l/installation/ This appeared to go ok. The guide then says that the resulting stream can be viewed in the PC browser simply by entering http://[RPi ipaddress]:8080/ I have tried entering this url in the PC browser (with or without the port number) but all I get is that ‘Site could not be reached’ or ‘refused to connect’

I can ping from the RPi to PC and the PC to RPI. I can connect to the router admin page from both the PC & RPi using the router's ipaddress. I also successfully use VNC to connect from the PC to the headless RPI as well as using WinSCP to transfer files between the two.

Could anybody please explain in easy terms what I am doing wrong? As I am a NOOBy I feel that I have probably overlooked something fairly simple. Many thanks in anticipation.


Info requested by goldilocks: After installing lsof and entering sudo lsof -i tcp:8080 resulted in no output.

I also entered sudo lsof -i tcp:1-1024 to check that lsof was installed correctly. This resulted in:

pi@raspberrypi:~ $ sudo lsof -i TCP:1-1024
COMMAND     PID USER   FD   TYPE DEVICE SIZE/OFF     NODE NAME
cupsd       535 root   10u  IPv6  11599      0t0    TCP localhost:ipp 
(LISTEN)
cupsd       535 root   11u  IPv4  11600      0t0    TCP localhost:ipp 
(LISTEN)
cups-brow   537 root    5u  IPv6  11639      0t0    TCP localhost:41146-
>localhost:ipp (CLOSE_WAIT)
vncserver   618 root   17u  IPv4  19936      0t0    TCP Unknown:47600-
>212.119.29.130:https (ESTABLISHED)
sshd        688 root    3u  IPv4  10193      0t0    TCP *:ssh (LISTEN)
sshd        688 root    4u  IPv6  10195      0t0    TCP *:ssh (LISTEN)
  • Edit in the output from sudo lsof -i tcp:8080. You may have to apt install lsof if it is not already there. – goldilocks Jan 8 '18 at 20:32
1

Having agonised over this for a few days I eventually came across this much more detailed guide on how to install uv4l:

http://www.home-automation-community.com/surveillance-with-raspberry-pi-noir-camera-howto/

This informs us that the Camera video stream can be seen by entering in your browser:
http://[pi-ip-address]:8080/stream (worked OK with Google Chrome on Windows 10)

or, if you have the VLC player on your mobile, you can open the network stream by entering:
http://[pi-ip-address]:8080/stream/video.mjpeg (worked OK on a Google Android phone).

I thought it would turn out to be something simple!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.