When connecting my pi via HDMI, I am getting no image. I can't see any additional devices on my network when connected via Ethernet.

LED panel has a strong red light on PWR, very dim green light on ACT. No other active lights.

I have read suggestions that this could be power related. I have no multimeter at the moment to verify the power, but the charger used was one that ships with the Samsung S3. As far as I can tell, the requirements are the same, and it is working on the phone (my electronics isn't great, so I could be wrong).

I have ordered a multimeter, but in the interim is there anything else I can try to isolate the issue?

The pi has never been used. It is not known to work as it has never been turned on since purchase. It is the first model (bought on release, and then left while I found the time to do something fun with it!!)


The card has a copy of Raspian on it. Installed using this method. I have now tried two cards. Both fresh out of the packet.


I have found occasionally that corrupt SD cards sometimes have the green OK LED maybe flash once at proper brightness, and then have the appearance of being extremely dull (very hard to see, but not quite off), almost looking like a light bulb filament when there is not enough power to light the bulb properly.

  1. Have you inserted an SD card into your Raspberry Pi?
  2. Has the SD card had an image put on it (using a program such as dd or Win32 disk imager)?
  3. Have you tried re-flashing the SD card?
  4. Have you tried another SD card (it may be damaged or the Pi might not work well with it).
  5. Did you try holding the SD card tightly? Sometimes the Raspberry Pi fails to detect the actual presence of a card

For more on detail on setting up SD cards see the eLinux page here.

| improve this answer | |
  • 1) Yes 2) Yes - See question edit 3) As in formatting and starting again? yes 4) I have now, no joy out of two brand new cards – Mild Fuzz Jun 2 '13 at 13:09
  • 1
    Four thoughts, 1) maybe your download is corrupt, use shasum filename on the downloaded file and compare with the downloads page 2) In the dd command did you use a drive device, such as of=/dev/sdb or a partition device such as of=/dev/sdb1, the former is what you need to use 3) I know it is a silly question but are you sure the /dev/... you used is the correct one, and not some other device? 4) It might be worth checking elinux.org/RPi_SD_cards to see if anyone else has had problemswith the cards you are trying to use. – PiBorg Jun 3 '13 at 7:08
  • Thought 2) saved the day. Sloppy kisses! – Mild Fuzz Jun 3 '13 at 18:50

according to this page : "A faintly glowing steady green LED means no boot code has ever been executed, as almost the first thing the boot code does is to turn the faint glow off! When flashing/blinking the green LED should be as bright as the red LED."

you have to check and/or replace your SD card and make sure you actually wrote a proper image in the proper place, it's easy to mess up, especially if you haven't done this before.

| improve this answer | |
  • Still no joy, see question edit – Mild Fuzz Jun 2 '13 at 13:09
  • @MildFuzz please, read my answer again. dim green LED means no boot code was ever executed from your SD card. if you are unable to write a correct SD card to boot from, ask your linux friend or as a last resort -- buy a ready-made bootable SD card. – lenik Jun 2 '13 at 17:15
  • Assume I have asked a 'linux friend' (we call him 'Google'), and he gave us several methods which we followed to the letter. We still have the same result. – Mild Fuzz Jun 2 '13 at 17:56
  • Do you have a specific issue with the DD method of deployment? – Mild Fuzz Jun 2 '13 at 17:57
  • @MildFuzz I don't, but looks like you do. Faint green LED means that the very first block on your SD card is not written properly. try to read it back and compare with the original. also it helps to ask your friend (a real one), who has RasPi to boot from your SD cards to make sure these work/don't work. or you may even ask your (real) friend to help you to make a working card. – lenik Jun 3 '13 at 11:58

Um, did you put an SD card in the PI with a distribution installed? Use something like this if you are on windows.

| improve this answer | |
  • Still no joy, see question edit – Mild Fuzz Jun 2 '13 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.