1

Raspi/Linux noob here.

Due to compatibility issues with another program, I need to install an older version of pymongo. 3.5.1 to be more specific.

I have used pip3 for the pymongo install. So, based on advice I found online, I tried:

sudo pip3 install pymongo==3.5.1

But this gives the error message Could not find any downloads that satisfy the requirement.

Does anyone know what I'm doing wrong? Or how to install a specific version of pymongo?

1

This is a similar issue to a previous Pip question — the pymongo package has architecture specific builds for x86 and x86_64 processors only. There is no ARM package available, so Pip isn't able to find a package that is suitable for your Pi.

The Raspbian repositories offer PyMongo 3.4.0, and you can install that with:

sudo apt-get install python3-pymongo

Otherwise, you will likely need to download the sources and compile/setup the appropriate version yourself, it appears.

  • No problem, @SomeRandomFinn. Don't forget that you can accept this answer with the checkmark if you solved this problem — that's our way of saying thanks on Stack Exchange. – Aurora0001 Jan 11 '18 at 15:41
  • sorry it took ages to accept the answer! (Linux noob and Stackoverflow noob to boot!) Added for posterity: turns out you can also install a version "older than" some specific version. (How cool is that!!!??) With (e.g.): sudo pip3 install 'pymongo<3.6.0' – SomeRandomFinn Apr 10 '18 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.