0

Can anyone help a n00b out? I should have enough space on my SD. df -h results are below. sda1 is for NAS storage.

I'd appriciate any input whatsoever, and thanks in advance.

sudo apt-get upgrade

Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... The following packages were automatically installed and are no longer required:
      x11-apps x11-session-utils xbase-clients xbitmaps
    Use 'apt-get autoremove' to remove them.
    Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    12 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] 
    Setting up apache2 (2.4.10-10+deb8u11) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package apache2 (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up cups-daemon (1.7.5-11+deb8u2) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package cups-daemon (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up samba (2:4.2.14+dfsg-0+deb8u9) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package samba (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up openssh-server (1:6.7p1-5+deb8u4) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package openssh-server (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of ssh:
     ssh depends on openssh-server (>= 1:6.7p1-5+deb8u4); however:
      Package openssh-server is not configured yet.

    dpkg: error processing package ssh (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of cups-core-drivers:
     cups-core-drivers depends on cups-daemon (>= 1.7.5-11+deb8u2); however:
      Package cups-daemon is not configured yet.

    dpkg: error processing package cups-core-drivers (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of cups:
     cups depends on cups-core-drivers (>= 1.7.5-11+deb8u2); however:
      Package cups-core-drivers is not configured yet.
     cups depends on cups-daemon (>= 1.7.5-11+deb8u2); however:
      Package cups-daemon is not configured yet.

    dpkg: error processing package cups (--configure):
     dependency problems - leaving unconfigured
    Setting up deluged (1.3.10-3+deb8u1) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package deluged (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of libapache2-mod-php5:
     libapache2-mod-php5 depends on apache2 (>= 2.4); however:
      Package apache2 is not configured yet.

    dpkg: error processing package libapache2-mod-php5 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of printer-driver-gutenprint:
     printer-driver-gutenprint depends on cups (>= 1.3.0); however:
      Package cups is not configured yet.

    dpkg: error processing package printer-driver-gutenprint (--configure):
     dependency problems - leaving unconfigured
    Setting up rsync (3.1.1-3+deb8u1) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package rsync (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up sane-utils (1.0.24-8+deb8u2) ...
    insserv: warning: script 'vpn.sh' missing LSB tags and overrides
    insserv: There is a loop between service minidlna and vpn.sh if stopped
    insserv:  loop involving service vpn.sh at depth 2
    insserv:  loop involving service minidlna at depth 1
    insserv: Stopping vpn.sh depends on minidlna and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package sane-utils (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     apache2
     cups-daemon
     samba
     openssh-server
     ssh
     cups-core-drivers
     cups
     deluged
     libapache2-mod-php5
     printer-driver-gutenprint
     rsync
     sane-utils
    E: Sub-process /usr/bin/dpkg returned an error code (1)

df -h

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.2G  4.9G  2.0G  72% /
devtmpfs        458M     0  458M   0% /dev
tmpfs           462M     0  462M   0% /dev/shm
tmpfs           462M  6.9M  455M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           462M     0  462M   0% /sys/fs/cgroup
/dev/mmcblk0p1   60M   22M   39M  37% /boot
/dev/sda1       466G  413G   54G  89% /media/hdd
tmpfs            93M     0   93M   0% /run/user/1002
tmpfs            93M     0   93M   0% /run/user/1000
0

You haven't told us what OS (looks old); WHAT YOU DID

It looks like some packages are corrupt;

Run sudo apt-get clean ; empty cache

Then sudo apt update

and retry

  • No luck. Clean and update had no return, but upgrade gave me the same error. – lolok Jan 12 '18 at 19:55
0

You do sudo apt-get upgrade. In man apt-get you will find to upgrade:

Packages currently installed with new versions available are retrieved and upgraded; under no circumstances are currently installed packages removed, or packages not already installed retrieved and installed. New versions of currently installed packages that cannot be upgraded without changing the install status of another package will be left at their current version.

You should try sudo apt-get dist-upgrade. In man apt-get it is said to this:

[..] also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages [..]. The dist-upgrade command may therefore remove some packages.

If that also doesn't help then you can try to purge the 10 defective packages by hand. I would start with rsync because it has not so much dependencies:

rpi ~$ sudo apt--autoremove purge rsync

Do this step by step with the remaining 9 packages, reboot and install them again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.