1

I'm trying to install an OpenVG library, but when I start to make it I get the error.

...
gcc -L/opt/vc/lib -lEGL -lGLESv2 -ljpeg -shared -o libshapes.so oglinit.o libshapes.o
/usr/bin/ld: cannot find -lEGL
/usr/bin/ld: cannot find -lGLESv2
collect2: error: ld returned 1 exit status
Makefile:35: recipe for target 'library' failed
make: *** [library] Error 1

I'm suspecting that this problem is because I just changed to Stretch ,but unfortunately I would rather keep using this library. Is there a way to fix this?

  • 1
    What's in your /opt/vc/lib? They should provide the EGL/GLES libraries. Try update your firmware and try again. – Kong Chun Ho Jan 12 '18 at 6:45
2

These libraries were renamed to libbrcmEGL.so and libbrcmGLESv2.so on Stretch, in order to reduce the risk of conflicting with their libgles2-mesa-dev counterparts. Edit the Makefiles to say -lbrcmEGL -lbrcmGLESv2 instead.

In fact, somebody already did that and submitted a pull request.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.