1

I purchased a Raspberry PI 2 two years ago and installed Raspbian Jessie at the time.

I configured several services including nginx/ssh/... with very specific settings so complete OS re-install is not an option.

It has been running smoothly for months without reboot.

I decided to upgrade to stretch six month ago. No errors so far.

I noticed after some time that since upgrading, the RPi freezes randomly after two days to a week and half of uptime.

I tried troubleshooting it by activating the SysRq key, to no avail. When frozen the SysRq key combinations don't work (-> works when not frozen). I also tried to find kernel logs after reboot in several places on the system -> no luck either, nothing unusual found in the logs.

Then, I tried to activate the "reboot on kernel panic" option using kernel parameters, because I need this RPi to be up 24/7 but the RPi doesn't even reboot on freeze.

I even tried to use a kernel debugger but couldn't find a way to activate it on the PI.

I don't know what to do next (I searched for months on the web for solutions), appart from manually plugging-off and on my RPi once I noticed it is not responsive anymore...

Am I the only one affected ? Anybody have an idea of what I can do to at least find the source of the problem ?

Additional info

  • The SD card I have is a Class10 - UHS-1 U1 "PNY MicroSDXC High Performance" card
  • The Pi is not overclocked
  • I did not change anything after upgrading to stretch, but still no crash before, crashes after
  • When frozen, both LEDs are lit
  • The power supply is 2A
  • The Pi crashes when idle most of the time (never crashed when I was actively using it)

Thanks in advance

2

If you decide to follow the unsupported "upgrade" from Jessie to Stretch you are expected to be able to resolve the many inconsistencies (including PHP5 and MySQL).

If you were satisfied with Jessie, restore from your backup.

Alternatively do a fresh install of Stretch (like almost everyone else).

  • I didn't know that upgrading to a newer distribution was unsupported, I just followed the steps provided in " raspberrypi.org/blog/raspbian-stretch ". I did resolve all the inconsistencies (upgrading to PHP7...). The only thing I could not resolve is this freezing problem. – jjth Jan 12 '18 at 10:45
  • @jjth Which states "As this is a major version upgrade, we recommend using a clean image; these are available from the Downloads page on our site as usual. Upgrading an existing Jessie image is possible, but is not guaranteed to work in every circumstance. If you wish to try upgrading a Jessie image to Stretch, we strongly recommend taking a backup first – we can accept no responsibility for loss of data from a failed update." – Milliways Jan 12 '18 at 10:50
  • 1
    I know how to read, "recommended" does not mean that the other option is unsupported. – jjth Jan 12 '18 at 10:55
  • @jjth We could argue semantics, but the bottom line is you are on your own. It really isn't that hard to replicate an installation. The reality is Jessie is still a viable OS, Stretch doesn't offer many advantages. – Milliways Jan 12 '18 at 11:17
  • In the end I backed-up all my files, did a fresh install of stretch and manually restored the services I needed from the backup. It seems to be the way to go so I will accept your answer. Thanks for your help – jjth May 2 '18 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.