1

I built a torrentbox (HD -> Powered USB Hub [has own outlet] -> Raspberry Pi 3 Model B) and got it working but it keeps remounting after a few minutes so after checking online, I changed /dev/sda to the HDD's UUID in /etc/fstab for it to work even if sd[letter] changes.

I encountered a new problem after. The remounting still occurred after a few minutes and so I tried to reboot Pi but now the HDD won't mount. and would sent me to emergency mode. I can still edit fstab but even if I changed UUID back into /dev/sda1, the error is still there. I'm not sure how to go about this could anyone advise?

Entries below based from what I've checked so far. Please help. ty.

on bootup :

[FAILED] Failed to mount /mnt/torrents.
See 'systemctl status mnt-torrents.mount' for details.
[DEPEND] Dependency failed for Local File Systems.

fdisk -l : HDD is present (/dev/sda and /dev/sda1)

/etc/fstab : mount doesn't even work after changing /dev/sda1 to its UUID and back

df -h results : doesn't show HDD /dev/sda1

systemctl status mnt-torrents.mount

Jan 12 19:18:33 deluge systemd[1]: Mounting /mnt/torrents...
Jan 12 19:18:33 deluge systemd[1]: mnt-torrents.mount: Mount process exited, code=exited status=32 
Jan 12 19:18:33 deluge systemd[1]: Failed to mount /mnt/torrents.
Jan 12 19:18:33 deluge systemd[1]: mnt-torrents.mount: Unit entered failed state.

journalctl -xb

Jan 12 19:18:33 deluge kernel: JBD2: Invalid checksum recovering block 1 in log
Jan 12 19:18:33 deluge kernel: JBD2: recovery failed
Jan 12 19:18:33 deluge kernel: EXT4-fs (sda1): error loading journal
Jan 12 19:18:33 deluge systemd[1]: mnt-torrents.mount: Mount process exited, code=exited status=32 
Jan 12 19:18:33 deluge systemd[1]: Failed to mount /mnt/torrents.

Add'l Info: I tried removing the line from fstab and mounting the hdd not from bootup and got the message that dev/sda1 is superblocked.

I've also tested if it was a power/faulty cable-related problem (maybe not enough power) and it still occurs even after replacing with working parts.

  • 1
    Adding info as pictures will decrease the chance to get help. – MatsK Jan 12 '18 at 19:25
  • Does the HD work on a different computer? – MadMike Jan 13 '18 at 7:31
  • The icon pops up in Windoes that its connected but i don't know if Windows should be able to load the HD via explorer if it was formatted to Linux. I don't have any other computer running Linux. If I were to reformat the HD would it work? It was empty and I've only started to DL into it so no important data needed to recover. – Kurover Jan 13 '18 at 8:27
  • Windows without any additional tools will not be able to read common Linux filesystems. Also Windows can't format a Linux FS in its own. So either you will need learn and use Linux or learn the approriate Windows tools to do this. Your choice. – MadMike Jan 14 '18 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.