2

Revisiting this issue Raspistill in manual exposure
I found that the shutter time of the photo I got from this command

raspistill -ss 6000000 -t 30000 -o long_exposure.jpg

is 6 seconds as expected but when I run this script

from picamera import PiCamera    
from time import sleep    
from datetime import datetime      
camera = PiCamera()    
camera.start_preview()    
camera.resolution = (3280,2464)     
camera.awb_mode = 'off'    
red, blue = (1.5, 1.45) # 5500K    
camera.iso = 100    
camera.shutter_speed = 6000000  # 6 secs     
datedate = datetime.now().strftime("%a-%d.%m.%Y-%H:%M:%S")     
nombre = '/home/pi/Pictures/IMG-' + datedate + '.jpg'     
sleep(2)    
camera.capture(nombre)    
camera.stop_preview()  

shutter time is 1/30 secs = 33333 nano secs

What am I missing?

1

Not sure if you're still having this issue, but it worked for me when I also set the camera.framerate equal to 1/exposure time, I think you have to do both or it will default to the default framerate of 30fps.

  • I marked this answer as correct because I can shoot manual slow speed despite I see some discrepancies like setting framerate=0.5 shutter speed=2000000 and the exif metadata outputs speed=1sec – dstonek Apr 20 '18 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.