0

So I attempted to boot my Raspberry Pi 3 running BerryBoot with raspbian and retropie installed, but it wouldn't boot. So I tried to plug my sd card into the computer, and instead of the boot partition appearing, it said it is corrupted, and I tried to format it, but the format failed. I've tried to use diskpart, ext2read and other similar programs, but all of them only show the 30mb partition, and even that cannot be formatted. I really hope that I can save my sd card, and I have tried everything. I just want to reformat to one fat32 partition and reinstall berryboot, ect.

Edit: The website believes that this is a duplicate of this:SD Card Showing as 30 MB on a 32 GB Card. Can't Format, Can't create a partition table but my problem is different. My partition is not unallocated, it is corrupted, and cannot be read or formatted. Also, that post had no solution, they just said get a new card, which I do not want to do mainly because I believe that this problem can be solved, I just don't know how yet.

marked as duplicate by Milliways, techraf, Steve Robillard, Jacobm001 Jan 19 '18 at 2:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    It appears this is a common issue, @Theo. While you might find a solution if you try hundreds of different things, you will save yourself a lot of trouble and frustration just replacing it as defective, I think. – Aurora0001 Jan 14 '18 at 10:39
1

When a SD card is in a corrupt state indicate that there is something wrong:

It could be the image transfer that went wrong = Try to transfer the image to the SD card again.

Or the SD card is damaged or counterfeit, that can be checked with as SD card program, there are many out there, use a search engine and search for "check sd card".

Not the answer you're looking for? Browse other questions tagged or ask your own question.