2

Many months ago I brought up a Raspberry Pi 3 with Raspbian Jessie. At the time, I enabled the VNCserver that came with Jessie. From my Mac (not sure what OS version) I was able to successfully use the then current version (5+) of VNCviewer.

Some months later I brought up a second Pi 3 with Raspbian Stretch. I enabled the VNCserver and at that time was able to use the same VNCviewer.

For a few months I toggled between the two systems for two different projects. I always used VNC (server/viewer) on both. The screen size was the default, which I think was 1024x768, but maybe larger. A few months ago, I put the second Pi 3 on the shelf. At about the same time I started using just SSH exclusively to access the first Pi 3 (with Jessie). Sadly, while I don't remember specifics, I may have done some updates/upgrades to Jessie.

I felt obligated to accept all the recent MacOS updates, and am now running High Sierra (10.13.2). Today I tried to use the VNC (server/viewer) on first Pi 3 with Jessie, and failed miserably. Using the "old" VNCviewer I apparently connected to the VNCserver (there were no error messages) but no screen appeared on the Mac. I fired up the second Pi 3 (with Stretch) and got the same results.

I installed the latest VNCviewer (6.17) on my Mac and tried again with both Pi systems. Jessie still fails, tho it does show a black 300x200 window. Stretch works, tho the window is only 640x480. [As an aside, nothing I've tried (-geometry and others) changes the window size.]

I checked the VNCserver log files for the two systems. Not surprisingly, they are different. The first lines for Jessie are:

VNC(R) Server 6.1.1 (r28093) ARMv6 (May 19 2017 13:21:25)

The first lines for Stretch are:

Starting Xvnc
Waiting for Xvnc...
VNC(R) Server 6.2.0 (r29523) ARMv6 (Aug 3 2017 18:55:38)

I tried to update the VNCserver on Jessie using

sudo apt-get install realvnc-vnc-server

but got a message saying "realvnc-vnc-server is already the newest version."

Going back to the log files, both contained identical information about copyrights, etc. and then identical error messages about font paths, symbols, etc. And at the end, both files contained "Starting session: /etc/X11/Xsession". For Stretch, that was the last line in the log file. For Jessie the log file ended with

(vncserverui:1049): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

I am at a loss to understand what is happening. Clearly something about MacOS High Sierra causes a VNCviewer problem with the older version. But something seems to have changed in my Jessie environment to break the VNCserver.

I am quite puzzled about how to fix this. I suppose in theory I could upgrade Jessie to Stretch, but that seems rather onerous. [Another aside, I'd like to know how to get a larger window size with the VNCviewer.]

Does anyone have any suggestions?

Thanks.

0

It sounds to me like you are now connecting to the vnc service mode server (which shows you what you'd see on a monitor plugged into the pi), whereas before you were connecting to a vnc virtual desktop. You need to put ":1" following the ip address or hostname in vncviewer to connect to the virtual desktop (assuming there's just the one running).

For more info on vnc server modes see https://www.realvnc.com/en/connect/docs/server-modes.html

  • Your answer was spot on. While the older version of VNCviewer still does not work, the latest version works for both systems simply adding the ':1' to the IP address. I had forgotten about that, tho I did do it to make the older version work in the past. Thanks! – gaflurry Jan 19 '18 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.