7

I am setting up the NOOBS (New Out-Of-Box Software) that has just been released. Once I have formatted and copied the data onto my Class 6 SDHC card, and plug my Pi in, the power light turns on, but my screen doesn't show anything, and the green "OK" light doesn't turn on either.

Specs:
PC: Windows XP SP3 Professional Refurbished, 2GB RAM
Pi: Model B with Samsung chip, Powered hub
SDHC: Transcend 4GB Class 6, connected to PC using HEISI SD Card reader. Has worked in the past with Raspbian, Arch and Pidora IMGs.

  • Not helpful, ppumkin. Crazyskeggy - you're not the only one to have the problem. Have you tried a different SD card? Could be compatibility issue with the card itself. – recantha Jun 5 '13 at 4:34
  • @recantha The SDHC crad has worked with the IMGs for Raspbian, Arch and Pidora, but I'm moving to NOOBS because I don't want to keep booting into a Lubuntu VM all the time. – Kieran Jun 5 '13 at 15:23
  • Things to check * that the SD card's write-protect tab is in the read-write position and not halfway in between. * that the little gold spring contact on the SD card slot makes contact where it should * that there's no horizontal movement of the card inside the slot – recantha Jun 7 '13 at 12:10
  • @Room34 I seem to have the same problem as you. The SD Card now read's RECOVERY in my Mac. However, I have tried different monitors and still the result is a black screen with the monitor claiming No Signal. Do I need to edit the config file on the SD card first? Any idea on how to get it running? – user12134 Jan 16 '14 at 22:10
3

Please note there was a problem with NOOBS v1.1 which meant many HDMI displays didn't work correctly, V1.2 (which is in RC right now) should fix these problems.

If not you can now press buttons 1, 2, 3, 4 to switch video mode between PAL, NTSC, HDMI (VGA), HDMI (preferred)

I tried mine last night and it now works correctly first time.

Gordon

  • Do you mean the 1, 2, 3, or 4 keys (one at a time)? Or do you mean simultaneously? My Pi doesn't have any buttons. – Dennis Williamson Sep 3 '13 at 1:19
5

I was having the same problem, but I noticed, curiously, that if I put the SD card back into my Mac, the Pi had renamed the volume from whatever I had called it to "RECOVERY", so obviously something was happening.

It occurred to me that the issue might actually just be that it wasn't supporting the monitor I was using. So I plugged into another monitor and it worked immediately.

I have read elsewhere that monitor compatibility with NOOBS could be an issue, and that adding a config.txt file with appropriate settings might resolve the issue. I haven't tried that yet but that is what I would suggest for anyone experiencing this same issue.

2

Adding the config.txt from a previous working installation made it work for me. It seems the recovery/installer comes right up without flashing the green light, but it didn't know about my monitor settings. Adding the config.txt allowed it to display and now it's installing. Thanks @room34 for the hint.

If you don't have a previous working version, use this default version, with safe mode enabled. After getting it going, read the config.txt instructions on the RPiconfig page to set the individual parameters that hdmi_safe enables to get better resolution for your monitor.

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt

Update:

The above allowed me to get the installer page to show up, but once the Raspbian install finished and I rebooted, I got a blank screen again. The first multi-color screen would appear, then a raspberry logo with no text, then the "press shift" screen, then nothing. But the green light was flashing so something was going on.

It took a bunch of attempts trying different things, then I finally realized that the new boot partition needed to get a config.txt put in it too. To do this, I had to run Puppy Linux on my primary machine so that I could see the additional partitions, since Windows will only work with the first partition on a flash drive. In Puppy (*) I copied the config.txt from the recovery partition to the boot partition, and then the monitor worked and I was able to get into my new installation.

(* any alternate Linux distro would work to do this, Puppy is just what I had on hand)

  • Thanks! I assume that is what happened when someone on the RPi forums directed me to replace the main version of NOOBS with the "output" directory on the Git repo. It's now working like a charm! (Apart from when it freezes (no response from mouse) at either 80 or 100% (before finish screen) install. – Kieran Jun 9 '13 at 20:21
1

There is quite an easy solution if the problem is to do with the type of monitor. NOOBS includes a Readme file, which contains the following lines:

"If your display remains blank, you should select the correct output mode for your display by pressing one of the following number keys on your keyboard:

  1. HDMI mode - this is the default display mode.

  2. HDMI safe mode - select this mode if you are using the HDMI connector and cannot see anything on screen when the Pi has booted.

  3. Composite PAL mode - select either this mode or composite NTSC mode if you are using the composite RCA video connector.

  4. Composite NTSC mode

"If you are still having difficulties after following these instructions, then please visit the Raspberry Pi Forums ( http://www.raspberrypi.org/forums/ ) for support."

0

Which decompression tool are you using? I had the same problem as you by using Ark for decompressing the file on Kubuntu. I tried even decompressing NOOBS lite but it didn't work.

Then, I used the command line tool unzip NOOBS.zip -d /media/user/SDcard and then it did.

Try using another decompression tool.

  • This was 2013, when NOOBS first came out - there was a bug with some TVs, as referenced in the answer I accepted. – Kieran Jul 26 '18 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.