0

I just clean installed Stretch and set up SSH and a hostname in raspi-config.

On occasion it takes several minutes after boot before I can SSH over IP. Sometimes it never happens and I have to power cycle the Pi.

Also, even though I have a hostname set greypi, ssh to pi@greypi.local has never resolved on Stretch for me. This worked fine in Jesse.

What could be going wrong?

Edit: SSH seems to more reliably work if I wait a few minutes after boot. If I try to connect much earlier it seems to lock me out. I enabled "Wait for LAN" in boot settings in the config and it din't help.

Edit2: I gave up. Sick of not getting mDNS or even SSH half the time. I went back to Jesse and it works a treat, therefore, not my network and not the Pi hardware I expect.

  • I cannot give you a solution. I occasionally have problems connecting. This is probably NOT a Pi issue (and not specific to Stretch), but related to the network or the source computer. I have found a ping greypi.local often wakes the network. Starting a new terminal session on my computer often connects. – Milliways Jan 18 '18 at 10:27
  • For the .local name to resolve, you need to have Apple's bonjour services available. Since it worked on Jessie, I assume you've done this bit. On a Windows machine, you need to specifically install bonjour. Can you ping the RPi during these intervals when you can't use ssh? Do you get any error messages? This sounds like your RPi can't be reached in general. Provide us the details of your networking setup. – bobstro Jan 18 '18 at 16:49
  • I'm connecting from a Mac so mDNS should be natively supported (indeed the same Pi reliably worked on Jesse). It used to be that you had to change the hostname in a few places and install mDNS on the Pi. But at some point, simply changing it in raspi-config was enough. Seems not now in Stretch? – square_eyes Jan 18 '18 at 21:37
  • I had my Pi on another network and was able to connect vial mDNS (.local). So now I'm thinking it's to do with my LAN. I know access point isolation can break such things but I don't have that installed. Last place to check will be my Powerline route. Will report back, although the SSH issue is still present making testing difficult. – square_eyes Jan 20 '18 at 8:52
  • Disabling WPS-PBC seemed to fix .local/mDNS on my home network (DIR-880L Router). I'm not sure what it is or when it was set. Rather odd. – square_eyes Jan 21 '18 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.