1

As specified in the title, I try to connect my Rpi 3 running Raspbian Jessie Lite from 2017-07-05 to my Windows 10 PC using puTTY on serial mode with this cable.

I tried to follow a few tutorials which led me to put :

enable_uart=0
dtoverlay=pi3-disable-bt

in my /boot/config.txt file and remove

console=serial0,115200

from my /boot/cmdline.txt file.

Cables wiring according to the amazon webpage :

Red +5V, Black GND, Green TXD, White RXD

I plugged my red cable on pin #4, black on pin #6, green on pin #8 and white on pin #10

Pin numbers according to this image enter image description here

Nothing appears on my puTTY window, and I become desperate.

If someone already faced the same problem or, at least, knows how to solve it, I'd be glad he helps me !

Please excuse my english, this isn't my first language.


Edit : The cable works fine on my Android Things Rpi3, so it's not coming from the cable

  • Forget whatever dodgy link you followed (which disabled BOTH Bluetooth AND serial) and enable serial from raspi-config. I STRONGLY suggest that you DO NOT connect the USB serial adapter 5V to the Pi 5V pins. – Milliways Jan 18 '18 at 10:49
  • So I remove every edits I did and ONLY use raspi-config ? – Maxime.D Jan 18 '18 at 10:50
1

You plugged the cables wrong. You have to plug RX to TX and TX to RX. Also plug ground to ground.

  • Thank you, I changed it, and used only raspi-config as @Milliways suggested and it works ! – Maxime.D Jan 19 '18 at 9:11
  • @Maxime.D Please mark this as the accepted answer - there is a tick you need to click under the voting buttons to the left – Quintin Balsdon Jan 19 '18 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.