0

I'm running headless Raspberry Pi Zero W with SSH. I'm trying to get VNC running so I can get to the GUI. My understanding is that I need to get raspi-config to run so that I can set VNC to "yes".

When I attempt to open sudo rasp-config, my cursor moves to the next line like it's working but it freezes and never goes any further.

I found the command sudo bash -x raspi-config on a GitHub post. When I run that the text of the menu comes back in the response, however, it's just text.

I've re-flashed the OS a couple times and see the same result. It seems based on the output from the above command that the menu tries to come back. Perhaps this is something in my PuTTY setup that I've messed up that's preventing this from working? FYI, I'm also attempting this from two completely different machines and see the same result in each.

I've also tried uninstalling and reinstalling PuTTY to no avail.

Anyone have an idea what will get me going?

0

The RealVNC included with Raspbian is designed to mirror a screen attached to the Pi (on RealVNC customised viewer).

It IS possible to to configure RealVNC to work without a screen, but you would be better to use tightvncserver, which creates a new virtual screen, and works with ALL VNC Viewers.

  • Thanks for your help but this failed as well. In each case it appears that I connect however the screen is black. – Shawn Jan 19 '18 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.