2

I am using a CP2102 Module to connect my PC with the Pi's GPIO port. Although there are some errors but now I can see some output every time I reboot the Pi.

[   49.739893] systemd-cgroups-agent[177]: Failed to get D-Bus connection: Failed to connect to socket /org/freedesktop/systemd1/private: Connection refused
[   49.757494] systemd-cgroups-agent[178]: Failed to get D-Bus connection: Failed to connect to socket /org/freedesktop/systemd1/private: Connection refused
[   50.958737] Restarting system.

I believe this means the physical connection and the hardware works OK. However, unlike what this article descripted, there are no boot up messages, nor can I access the console login.

The Pi is running ArchlinuxARM, what can I do to activate the serial console?

UPDATE

(Content moved to the answer.)

  • Perhaps ArchlinuxARM doesn't use the UART for the console by default – John La Rooy Jun 5 '13 at 12:09
  • Emm... So why the shutdown message shows? – Earth Engine Jun 5 '13 at 12:20
  • No idea. PL2303 module worked fine for me with raspbian – John La Rooy Jun 5 '13 at 12:27
  • 1
    Are you using screen or minicom? I can confirm screen works with the CP2102, but minicom gave me problems. Also, does ps aux | grep getty shows a process running? (Paste the output if you don't understand it) – GuySoft Jun 5 '13 at 22:00
  • I was using minicom and gtkterm. I will try ps aux | grep getty when possible. – Earth Engine Jun 5 '13 at 23:52
1

Following some suggestions in the comment, ps aux | grep getty shows no ttyAMA0 instances so the serial console is not started. Following the official Archlinux guide for Raspberry Pi, I enabled the console:

systemctl start getty@ttyAMA0
systemctl enable getty@ttyAMA0.service
ln -s /usr/lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@ttyAMA0.service

I can now connect to the serial console. By editing the cmdline.txt as the following, the kernel message shows up as well:

loglevel=5,console=ttyAMA0,38400 kgdboc=ttyAMA0,38400 (...other options)

FURTHER TIPS

If the Pi is powered by the PC through a USB cable, since they share the same ground, only TxD and RxD need to be connected. If the Pi is using another power source, Connect the Ground cable as well otherwise the console will keep receiving rubbish data.

  • 1
    Glad I could help out :) (a vote up to my helping comments would be nice) – GuySoft Jun 7 '13 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.