5

I have installed the "RASPBIAN STRETCH WITH DESKTOP" from https://www.raspberrypi.org/downloads/raspbian/

I have plugged in my camera module correctly (blue stripe facing towards the Ethernet port) to my Raspberry Pi 3

I have updated the packages

1) sudo apt-get update
2) sudo apt-get upgrade

and have also enabled Camera in raspi-config by doing $sudo raspi-config

But still the camera module is not getting detected.

Below are the logs of my Raspberry pi console.

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.9.77-v7+ #1081 SMP Wed Jan 17 16:15:20 GMT 2018 armv7l GNU/Linux


pi@raspberrypi:~ $ vcgencmd get_camera
supported=1 detected=0


pi@raspberrypi:~ $ raspistill -o photo.jpg
mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

I have also tried $sudo rpi-update to update the firmware but still the camera is not working.

I have followed this post Raspberry Pi Camera Rev 1.3 is not detected , but still no good.

Update:

I used the following command on the Raspberry pi terminal and then the camera worked.

$ sudo modprobe bcm2835-v4l2
1

I've tried with last RASPBIAN STRETCH LITE (9.4 - 2018-06-27) in a PI3B v1.2 with a PI CAMERA 2.1.

If this command doesn't detect the camera with "detected=1" like this:

pi@raspberrypi:~ $ vcgencmd get_camera
supported=1 detected=1

Then there is a connection problem. Check if the cable both ways are with the good side to the pins (and of course connected to the "camera" bus, not the "display" bus that are the same size).

(of course, after enable camera interface with raspi-config and rebooting)

If it didn't work, usually it's a hardware problem with the camera and the quick option is to change the camera with a new one.

If detected=1 but when trying to use raspistill shows this message:

pi@raspberrypi:~ $ raspistill -o test.jpg
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Then the connections are ok, but the problem for sure is a hardware problem with the camera and you have to change the camera for a new one. Don't waste time trying to solve it because it's a defective camera.

  • I had that recently, it was the push connection on the lens side had popped off slightly. Worth a double check. – Andy Anderson Sep 28 '18 at 8:51
1

I used the following command on the Raspberry pi terminal and then the camera worked.

$ sudo modprobe bcm2835-v4l2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.