3

I have a Raspberry Pi 3 Model B and have been running the latest Raspbian (9.3 Stretch) from the Pi website. I tried following the instructions for using Git to get RetroPie and everything went fine until I tried to run the script (sudo ./retropie-setup.sh) I get the following error:

Sorry - Raspbian/Debian Stretch (and newer) is not yet supported on the RPI.

Is this telling me that RetroPie is incompatible with my version? Is there a way to make it work? If not, can I uninstall all that I loaded with:

sudo apt-get install git lsb-release
cd
git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git
1

Is this telling me that RetroPie is incompatible with my version?

Yes. This is noted on their bug tracker; you'll have to use Raspbian Jessie instead. A recent pull request to their Git repository suggests that this is being worked on, but, for the moment, you're out of luck.

To get rid of git and lsb-release, the packages you installed, run:

sudo apt-get --purge remove git lsb-release

The command git clone ... will have created a directory called RetroPie-Setup. Just delete that as normal (for example with rm); essentially, all Git has done so far is download a repository into a directory on your Pi. Deleting that is all you need to do.

  • 1
    Perfect, everything is as it should be! I got another card for RetroPie and just "dual boot" when I want to switch. Thank you for the GIT education as well. – Fred Feb 2 '18 at 16:32
2

As of March 20, 2018, RetroPie's install script should now support Raspbian Stretch.

I (inadvertently) tested this for myself two days ago with a manual install. I ran the RetroPie setup script on my Raspberry Pi 3 Model B+ with a fresh install of Raspbian Stretch, unaware of any compatibility conflicts. Afterwards, I was able to boot into RetroPie without issue.


To fix your installer, update your RetroPie setup script to the latest version:

cd
git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git

Then re-run the setup script.

cd RetroPie-Setup
chmod +x retropie_setup.sh
sudo ./retropie_setup.sh

For future readers looking for a full install guide: refer to the RetroPie Manual Install guide.

0

As a confirmation, Retropie now works for me also not Raspbian Stretch!

I installed Jessie for Retropie because it didn't work on stretch back then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.