2

I've recently set up a Retropie which I have plugged into my TV. If I have the right input selected on the TV before powering on the Pi, then the image looks crisp and wonderful. However if I turn on the Retropie first and then flip the input over, it seems as though it chooses a default resolution which is not ideal because it isn't able to auto-detect anything.

Currently I have these two lines uncommented in my /boot/config.txt file:

hdmi_force_hotplug=1
hdmi_drive=2

I believe I need to set some combination of hdmi_group and hdmi_mode in order to force it to automatically choose the proper resolution (or maybe overscan_ or framebuffer_ values?). But I found the documentation to be very terse and am unsure what the proper values would be.

For reference, here is the output I get when I call fbset -s when the input is correct:

mode "1824x984"
    geometry 1824 984 1824 984 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,8/24
endmode

And here's what I get from that same command when the input is not correctly set before booting:

mode "640x480"
    geometry 640 480 640 480 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,8/24
endmode

What do I need to change to ensure it always boots with a fixed resolution of 1824x984?

2

You simply uncomment the line and set it with the resolution of the TV :

framebuffer_width=1824 #set the resolution of the TV
framebuffer_height=984 #set the resolution of the TV    

in /boot/config.txt

| improve this answer | |
1

Setting only framebuffer_width/framebuffer_height was not enough for me.

Had to resort to raspi-config which set these parameters in /boot/config.txt:

framebuffer_width=1920
framebuffer_height=1080
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.