1

I downloaded the .gz file from https://sourceforge.net/projects/gphoto/files/ (libgphoto2-2.5.16.tar.bz2), uncompressed it, un-tarred it.

Then from the command line, I ran

  autoreconf --install —symlink
  ./configure
  make
  sudo make install

There were no obvious errors, and if I go to /usr/local/include and /usr/local/lib I see relevant files. But I don't see the gphoto2 binary anywhere and trying to run gphoto2 results only in "command not found".

I am open to any suggestions.

1

Your issue is that you've installed the 'backend' library, libgphoto2, but not the front end command line tool, gphoto2. As noted in the documentation, Finding what you need:

What you need:

[...]

  • libgphoto2, some libgphoto2 frontend and (if you want to use USB cameras) libusb

libgphoto2 frontends

  • gphoto2

    Our own official command line interface (CLI) frontend. Simple command line interface and kind of a reference implementation. This libgphoto2 frontend is very useful for debugging camera drivers and other problems.

You can download and install the front end gphoto2 source from here (gphoto2-2.5.15.tar.gz). Once this is installed, you will be able to find and use the binary as expected. Alternatively, you can choose one of the other listed front ends, if you decide that you like one of those more.

  • 1
    You are correct, though now I'm getting gphoto2: error while loading shared libraries: libgphoto2_port.so.12: cannot open shared object file: No such file or directory when I run the binary. Any thoughts on that? – Michael Stern Jan 27 '18 at 18:09
  • I did a little digging, @Michael, and found this thread which suggests that the libraries aren't in your linking path. Check /etc/ld.so.conf to see if /usr/local/lib is included, and if not, add it and rerun ldconfig. – Aurora0001 Jan 27 '18 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.