1

I've got the following issue: I've attached a display to my Raspi 3B by using the SPI interface. It has been working fine for months, but a couple of weeks ago, the display suddenly stopped working despite apparently getting enough current (the cathodes are glowing). I checked all cables and found nothing abnormal, so I used the spincl utility to send commands to the display:

pi@autoradio:/import/valen/autoradio/spincl $ sudo ./spincl -ib
pi@autoradio:/import/valen/autoradio/spincl $ sudo ./spincl -m3 -c9 -s0 -p0 1 0x14

Every time I tried this out, spincl simply stopped and had to be killed with ^C. So I connected pins 19 (MOSI) and 21 (MISO) to each other so that SPI should now talk to itself. No use: spincl stopped again!

SPI has been enabled in raspi-config all the time.

UPDATE: Upon recommentation of another user, I ran gpiotest on the naked Raspi. Here's the result:

pi@autoradio:/import/valen/autoradio $ sudo pigpiod
pi@autoradio:/import/valen/autoradio $ sudo ./gpiotest
[…]
Skipped non-user gpios: 0 1 28 29 30 31 
Tested user gpios: 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 
Failed user gpios: None

What's going on here?

0

You have provided very little in the way of diagnostic information.

Perhaps your GPIO have developed a fault.

Try wiringPi's pintest utility.

Or (my) pigpio's gpiotest utility.

  • OK, I've run a bunch of tests with spidev_test and spiSpeed. The spidev test delivered exactly the expected result shown here, and spiSpeed showed me an error when testing messages with length 8192: Message too long. For gpiotest I would have to detach all devices hanging on the 40-pin header, including HATs, right? – Neppomuk Jan 28 '18 at 13:28
0

After a thorough check of the wires leading to the display, I found out that the soldering of one of the ground wires (which is soldered to the GND connector of a USB cable, which is itself plugged into the UPS of my Raspi) had gone loose (which was invisible at first glance). Unfortunately, it wasn't just some GND pin, but display pin #20, which must be pulled to GND for the display for its SPI interface to work. After resoldering this wire, everything now works fine. :)

Shame over me!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.