0

The link below shows the images of the output error, i`ve been working this for hours I follow instructions from here but still doesnt work . Hoping that someone would help me figure out the problem , Im using raspberry pi 3 model b++ , and raspbian jessie os from the here

images

Update heres the file from /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf here!

country=PH
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="EML33T2"
    #psk="emrooftop"
    psk=c150059ac2d9df589127a8ee0a1cc475099c2d6e60ea48644c21684cb7ee6b23
}

network={
    ssid= "test"
    psk= "testingi"
    key_mgmt=WPA-PSK
}

For interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
sources-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug intwifi0
iface intwifi0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
  • it would be helpful to see the file /etc/wpa_supplicant/wpa_supplicant.conf and the /etc/network/interfaces because the error obtains of parsing the needed files. And finally he could not start the wlan0 interface – bierschi Jan 28 '18 at 1:53
  • @bierschi I updated my post , link is the file in mentioned directory – Boy Bawang Jan 28 '18 at 2:05
  • 1
    DO NOT post links - post TEXT. – Milliways Jan 28 '18 at 2:30
0

I think /etc/network/interfaces is configured correctly. So change your /etc/wpa_supplicant/wpa_supplicant.conf file into this way:

country=PH
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="your_SSID_from_router"
    psk="your_secret_password"
}

Ensure that ssid and psk absolutely correct to the settings of your router. Set the psk into quotes. And write only one network={} statement into this file and try to restart your wlan interface

Useful commands:

scan available networks:

sudo iwlist wlan0 scan

switch on and off the wlan0 interface

sudo ifconfig wlan0 down
sudo ifconfig wlan0 up

restart the whole network interface:

sudo service networking restart
  • After using the command iwlist wlan0 scan @bierschi I got this error image – Boy Bawang Jan 29 '18 at 9:32
  • no wlan device is running. First ensure with ifconfig that a wlan interface is up like wlan0 or wlan1. If one wlan interface is up you can use the command sudo iwlist wlan0/wlan1 scan. – bierschi Jan 29 '18 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.