0

I installed Raspbmc and everything is working fine except for the purple tint. (Also happening in XBian)

The Raspberry Pi is connected to the tv via HDMI.
The HDMI cable works fine when connected to my PS3. The RCA jack isn't working so I can't test with that.

Also, when Raspbmc is booting, the logo screen has a black background at the start but it turns purple near the end of the boot.

I took a video of it: http://www.youtube.com/watch?v=tYhnEPv-I44

  • Can you test on a different television? Make sure its not some preset there? – GuySoft Jun 8 '13 at 16:27
  • Unfortunately I only have one tv. I've gone through the settings on my tv but there was nothing that helped. – Trev Jun 10 '13 at 1:46
1

I figured it out...

I had to edit /boot/config.txt and add the following line:

hdmi_mode=5

I started by adding hdmi_safe=1 and tweaked it from there.

Here's a link describing the settings in config.txt: http://elinux.org/RPiconfig


Fix for OpenELEC v3.2.4
Add the following line to /flash/config.txt

hdmi_mode=5

Fix for OpenELEC v4.0.7

Make /flash writable using

mount /flash -o remount,rw

Add the following 2 lines to /flash/config.txt

hdmi_group=1
hdmi_mode=5
  • I just installed OpenELEC and it had the same problem. The fix is the same but the location of config.txt is different. It's located at /flash/config.txt – Trev Mar 9 '14 at 19:16
  • ... and it continues... I just upgraded OpenELEC v4.0.7 with the same problem. The config.txt file was still at /flash/config.txt but I had to make /flash writable using mount /flash -o remount,rw. I also had to add hdmi_group=1. – Trev Sep 10 '14 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.