1

I use VNC viewer to connect my Pi 3, laptop and Kuman 7" touchscreen, because I cannot get access to a keyboard or mouse. When I open minecraft-pi it shows just a black screen on my laptop, but it loads on my pi screen, and I can click in and play (only the mouse works, the keyboard doesn't). How do I make my laptop's keyboard work with minecraft-pi if it works usually in other circumstances such as editing code, and how can I make it show up on my laptop?

1

I'm assuming your using RealVNC on the Pi. You need to turn on the 'experimental direct capture mode'.

To turn this feature on, open the VNC Server dialog, navigate to Menu - Options - Troubleshooting, and select 'Enable experimental direct capture mode'

https://www.realvnc.com/en/connect/docs/raspberry-pi.html

  • What do you mean by 'Server Dialog'? When I open VNC, I only get 'File', 'View' and 'Help' on the top bar and none of them contain 'Menu'. – Shawn Li Jan 29 '18 at 21:13
  • On the Pi you should have a VNC icon on the task bar, right click should give a menu. – CoderMike Jan 29 '18 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.