0

I'm trying to use my RDM6300 module with the Raspberry Pi 3 as show on this site: https://behindthesciences.com/electronics/raspberry-pi-rfid-tag-reader/

I disabled the terminal tty by putting in /boot/config.txt

dtoverlay=pi3-disable-bt
enable_uart=1

I wired the module to 5V, GND, GPIO 8 and 10 (BCM 14 and 15) but I can't still communicate with the module using the serial port. I'm using this python script

import time, serial

sl = serial.Serial("/dev/ttyS0", 9600)

while True:
    ID = ""
    read_byte = sl.read()
    if read_byte == "\x02":
        for i in range(12):
            read_byte = sl.read()
            ID = ID + str(read_byte)
        print(ID)

and the kernel 4.9.78-v7+

3
  • With linux 4.14.18-v7+ the serial port is now working fine.
    – Marco
    Feb 19 '18 at 18:47
  • I am having the same issue and tried to follow the answer below with no luck. Did you end up using ttyS0 or serial0? I have linux version > 5. Are there any other configuration issues you found that you needed to change? Sep 12 at 7:55
  • Hi @russelrillema . Honestly, I have no idea. The system was in prod with the same kernel up to few months ago, when was dismissed. Sorry!
    – Marco
    Sep 13 at 8:04
1

Have you try to the see list of peripheral in ls /dev?
Have you try sl = serial.Serial("/dev/serial0", 9600)?

5
  • Alright, i can see /dev/serial0 and /dev/serial1 but no one is receiving data from the module (i near the key and nothing is shown either via minicom)
    – Marco
    Jan 31 '18 at 17:51
  • Do you have invert RX and TX?
    – 2CoB9
    Feb 1 '18 at 9:37
  • Try to delete console=serial0,115200 in /boot/config.txt
    – 2CoB9
    Feb 1 '18 at 9:38
  • Yes i tried to invert RX and TX without any result. I have no console=serial0,115200 neither in /boot/config.txt nor in /boot/cmdline.txt . Loopback is working fine (connecting RX and TX togther) and the same module on my Sunfounder mega is working fine too.
    – Marco
    Feb 1 '18 at 14:59
  • serial.Serial("/dev/serial0", 9600) worked for me using the python3-serial package
    – Sven Rojek
    Aug 16 '18 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.