1

VNC Viewer cannot connect to a Pi 2 configured with a proxy address.

I've modified /etc/environment to add my college's proxy so that I can access the Internet after connecting to my college's ethernet connection. export http_proxy="http://172.16.19.10:80/"

After this, whenever I try connecting to the Pi via VNC Viewer, I get an error, though I can connect to SSH without any problems.

Unable to connect via 172.16.19.10:80: disconnected by proxy.

VNC Viewer error

  • 1
    I suggest you enable debug logging in the VNC Viewer (you can find it in the preferences dialog). Then run it again and see if anything useful gets written to the log file which may give you more information as to why it's failing. – Andrew Wedgbury Feb 2 '18 at 9:10
1

Solved by disabling proxy for VNC Viewer in File -> Preferences -> Proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.