2

So I have the RPi connected to a Samsung TV that supports CEC/Anynet+ , which is awesome. I'm using XBMC and it can stream 720p video to my TV through my network share only using my TV remote, and that's ultra cool. Also got the sound working through HDMI without a config file, so that's great too.

However, my only remaining issue is that every few minutes, the video will cut for a very tiny fraction of a second. I can't even hear the sound cutting, the video doesn't actually stop or jitter or anything, it's just that the display kind of "resets". The TV shows the channel and the current time just like if I had changed the input selection.

It does this at a variable rate, anywhere between a minute and 5. Since I'm using XBMC, I'm not sure where I should look for logs, if there are any. It does not do this in the menus, only specifically when playing a video.

Update: It seems that this does not affect XviD files, as I've watched multiple episodes of a show that is in this codec and it doesn't happen. However, an MKV does it, and an H264 AVI does it too. Basically, only xViDs are safe as far as I can see? So this isn't all video and definitely not a cable issue.

3
  • 1
    It may be the tv resetting the connection. Is the cable of high quality? Jun 8, 2013 at 23:30
  • 1
    You might want to look at the hdmi_***** options inside /boot/config.txt
    – Gerben
    Jun 9, 2013 at 9:49
  • I believe my solution was to install a different XBMC build, though off the top of my head I can't remember which one it was. Mar 11, 2014 at 16:36

2 Answers 2

1

Try putting dispmanx_offline=1 to your /boot/config.txt and reboot your Raspberry. That should help.

Source: http://wayland.freedesktop.org/raspberrypi.html

When there are too many things on screen for the on-line compositor to handle, the output dies or becomes corrupt without the off-line fallback.

0

I'm working with a samsung right now, and have seen this problem with just a console screen. It's very intermittent, so will take a while to confirm the cause.

The usual suspects are

  1. Power Supply - better power supply seems to help
  2. Long HDMI cable - try shorter/better cable
  3. Marginal HDMI signal - try config_hdmi_boost=4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.