2

I'm trying to run chromium-browser on my raspberry pi (stretch 4.9.67-v7+) but I keep getting the error:

/usr/lib/chromium-browser/chromium-browser: error while loading shared 
libraries: libbcm_host.so: cannot open shared object file: No such file 
or directory

It worked before but stopped working when I uninstalled some other package. I've tried reinstalling the package several times and I also tried adding the libbcm_host.so in /usr/lib and /usr/local/lib manually from https://github.com/raspberrypi/firmware/tree/master/opt/vc/lib and then running sudo ldconfig -v. It pops up in the trace as

libbcm_host.so -> libbcm_host.so

under both /usr/lib and /usr/local/lib but running chromium-browser still gives me the same error.

Any thoughts?

2

The problem was that the /opt/vc folder had gone missing. The issue was resolved by installing the libraries again with:

sudo apt-get update
sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-dev libraspberrypi-doc libraspberrypi-bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.