1

Tried RaspBMC, xBian. Having trouble with wifi connecting using xBian. And having wifi troubles at home with RaspBMC. It's making me mad wasting lots of hours trying to fix it without a clue what's going wrong..

Yes, there are no special characters in the SSID and the SSID isn't hidden. Yes, there are no special characters in the password.

Also I'm always able to see the SSID with either network-manager or the native connection manager. But while trying to connect to the router it just stays on connecting for a couple of seconds and then it just shows disconnected.

What the hell is the best way to fix this? What's the main approach of solving wifi connection difficulties on a RPi? Some kind of log through SSH?

I love the RPi, but this really discourages me wasting 2 days on trying to solve this.

Wifi adapter: Sitecom 300N USB Adapter

Router: Sitecomm WLR-2000

Any help appreciated!

  • the raspberry pi has no wifi adapter. therefore 1)this question most likely does not belong here, and 2)you'd better tell your wifi adapter model and your router model -- this would definitely help you to get answers. – lenik Jun 9 '13 at 3:49
  • That's plain nonsense what you said there. This place not being used for raspberry using other hardware. It's still about the RPi. Router and adapter added, don't think it'll be of any help since the hardware connection is working and I'm asking where to find some sort of log to find the problem with initialising the connection. – Sem Jun 9 '13 at 11:01
  • Thanks for this entire posting. I had exactly the same problem. Now I have a fighting chance to get this wifi connection going. – user9143 Aug 22 '13 at 0:55
1

I ended up setting up my wifi connection through the command line. You can get a bit more debugging information that way depending on what program you are using to connect - e.g. with wpa_supplicant, you can pass the '-d' or '-dd' options to see varying amounts of debugging info.

BTW, I'm using an Edimax EW-7811UN wifi adaptor with WPA Personal encryption, and here is what I needed to set my configuration files to before restarting the computer:

/etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -B

iface default inet dhcp

/etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="SSID"
        psk="PASSWORD"
        scan_ssid=1
        key_mgmt=WPA-PSK
        proto=RSN
        pairwise=CCMP
}

You may have to change this line

pre-up wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -B

if your wifi adapter is not supported by the default wifi extensions in Raspbian. The -D parameter refers to which driver to use, so I'm using 'wext' which is the default.


If you are not using WPA, this article has some good information on wifi networking via the command line in linux: http://www.ghacks.net/2009/04/14/connect-to-a-wireless-network-via-command-line/

In summary, use the commands

sudo ifconfig wlan0 up # To initialize your wifi adaptor
sudo iwlist wlan0 scan # To see if you can see your network
sudo iwconfig wlan0 essid NETWORK_ID key s:WIRELESS_KEY # To connect
sudo dhclient wlan0 # To set up an IP address through DHCP
  • Awesome man, can't thank you enough! Now I know where to begin. – Sem Jun 9 '13 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.