0

A couple of weeks ago, I had a functioning mesh network that used batman-adv for the mesh functionality. In order for it to work, I needed the cell address that can be set in "sudo iwconfig wlan0 ap any", where wlan0 is the network interface, and "any" is the configuration for apm, to be the same address across all the Pis in my network. This worked perfectly fine with the exact same command given above, and all the Pis in my mesh had the same Cell address automatically and they'd be in one mesh network.

However, as of a couple of days ago, this appears to have stopped working. Now, each Pi automatically gets assigned random, and different, Cell ids and I can no longer set all the Pis to have the same ID. This, as expected, completely breaks my mesh network.

From my searching, another user appears to have the same issue (RPI3b (Raspbian): Cannot set Ad-Hoc AP Cell ID when ESSID is defined).

Is there any way to fix it? What could have caused it to work, and then now not work? I've tried reflashing the Pis and doing the same configurations as before, and still nothing.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.