1

Okay. Have looked like crazy for a specific topic but can´t find any problem that matches mine.

I have Rpi3 with a rpi2 camera. It has worked fine before but haven´t been using it for some time.

Now whenever I try to run raspstill the image is just green like the provided image.

Verbose mode doesn´t give any clues. Looks like it should and camera is enabled and detected.

My suspicion is the ribbon cable that one of the wires is broken. Could one broken wire within the ribbon cable cause this problem or Am I missing something

I´m using rasbian and have done a rpi-update. But nothing I do seems to do the trick. The videos get empty too.

Any clues?

green images

  • Ohh... forgot to mention. Running it on the mains. – Mathias Junker Lundstrm Feb 6 '18 at 19:58
  • "whenever I try to run raspstill" - please add the code/your cli input to take picture and video – Fabian Feb 21 '18 at 15:22
1

I had the same issue - seems like the camera module got damaged in some way (probably from electrostatic discharge). It had worked fine a few weeks prior.

I ordered a new camera module and everything works fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.