I use this RPi Zero W mainly from ssh.
All updates and upgrades performed.
I wanted to install an app from its website.
No way.
Attaching keyboard, mouse and monitor I opened Chromium and the resources monitor (screen bottom right) raised to 100%.
Chromium is to slow to do any action like display "Restore last session?", "Okay" or "Cancel".
At the same time, from ssh top shows me that %Cpu varies around 30% and Mem from 362816KB there were around 180000KB free.

Finally system crashes.
top with system idle:

Tasks: 127 total, 1 running, 126 sleeping, 0 stopped, 0 zombie
%Cpu(s): 7.2 us, 4.9 sy, 0.0 ni, 87.6 id, 0.0 wa, 0.0 hi, 0.3 si, 0.0 st
KiB Mem : 362816 total, 262296 free, 57488 used, 43032 buff/cache
KiB Swap: 102396 total, 34704 free, 67692 used. 254592 avail Mem

Reboot with display, mouse and keyboard connected:

Tasks: 129 total, 1 running, 128 sleeping, 0 stopped, 0 zombie
%Cpu(s): 11.3 us, 8.3 sy, 0.0 ni, 80.4 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem : 362816 total, 251144 free, 71004 used, 40668 buff/cache
KiB Swap: 102396 total, 50992 free, 51404 used. 246264 avail Mem

Start Chromium from screen icon raises resources indicator to 100%. It takes around 4 minutes to display Chrominum window.
Meanwhie top

Tasks: 135 total, 1 running, 134 sleeping, 0 stopped, 0 zombie
%Cpu(s): 11.9 us, 34.3 sy, 0.0 ni, 0.0 id, 50.8 wa, 0.0 hi, 3.0 si, 0.0 st
KiB Mem : 362816 total, 257020 free, 74380 used, 31416 buff/cache
KiB Swap: 102396 total, 13896 free, 88500 used. 247712 avail Mem

1076 pi 20 0 550024 13564 8780 D 9.3 3.7 0:18.27 chromium-br+
21 root 20 0 0 0 0 D 8.7 0.0 1:11.53 kswapd0
69 root 20 0 0 0 0 S 8.4 0.0 0:43.18 mmcqd/0
1544 pi 20 0 257244 11444 7344 D 7.5 3.2 0:00.79 chromium-br+

During the time I was writing all that resources indicator is still 100% (I didn't touch anything in the screen)

df -h

Filesystem Size Used Avail Use% Mounted on
/dev/root 13G 5.4G 7.0G 44% /
devtmpfs 49M 0 49M 0% /dev
tmpfs 178M 8.9M 169M 5% /dev/shm
tmpfs 178M 5.0M 173M 3% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 178M 0 178M 0% /sys/fs/cgroup
/dev/mmcblk0p6 68M 22M 47M 33% /boot
tmpfs 36M 0 36M 0% /run/user/1000
/dev/mmcblk0p5 30M 454K 28M 2% /media/pi/SETTINGS2

After an hour the mouse pointer moves in a discrete way (not continuous) and ssh is too slow.

4 Answers 4


Take a look at your gpu memory split when running raspi-config from command line, Or from the gui version. Make sure it is 64,or 128MB.

It certainly sounds like your running out of resources. There may have been a big spike in RAM usage that wasn't caught in the update interval of top.

You can check to see if swap is enabled, and if it is being used during the start up of chromium. If you clear the swap file (disable and then enable again) Then try starting Chromium again, now from command line you can use


Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.5G  2.0G  5.3G  27% /
devtmpfs        484M     0  484M   0% /dev
tmpfs           489M     0  489M   0% /dev/shm 
tmpfs           489M   56M  434M  12% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           489M     0  489M   0% /sys/fs/cgroup
/dev/sda1        41M   21M   20M  52% /boot
/dev/sda3        14G  782M   13G   6% /var
/dev/sda4       923M  802M   58M  94% /swap
tmpfs            98M     0   98M   0% /run/user/1000

and in this example the /swap is almost full. Had I just clear swap, this would indicate that some process just used it. Now keep in mind that the percentage does not indicate if a process is CURRENTLY using the swap file, just that is was used at some point. You do not want to disable swap if you think a current process is using it as it might make it crash.

  • GPU is set to 144MB. sudo swapoff -a takes a while and then Killed but it seems it is not killed.top displays 58MB used. I am going to add some extra info in my question
    – dstonek
    Feb 8, 2018 at 16:13

Possibly this helps: I got an acceptable performance by:

  • using the KDE Desktop
  • disabling cups and step by step several other services. This is a trial and error action and needs to be taken one by one
  • moving directories /home and /var to individual partitions on an external harddrive.
  • I have experimented with the swap settings but have commented out all values in /etc/dphys-swapfile now. A test with zram.sh failed also. It looks like KDE is using own settings for the swapping.

My system:

  • Raspberry Pi 2B 4.14.71-v7+
  • raspbian stretch lite
  • 256 MB for GUI
  • Overclock settings 1000
  • KDE Plasma 5.8.6
  • 2 USB Wifi adapters TP-Link TL-WN725N (Not any compiling was required, the adapters have been recognized by the system)
  • No wired network connection, I just have used a smartphone->usb connection for the initial setup, so internet runs by wifi now.

In my apartment wifi is available as hotspot, but only one connection per party available. The Raspberry works as ap/router, so that I can connect further raspberries, laptops and a smartphone simultaneously. Before making the changes Chromium was extemely slow as in your problem-description

not working yet on this raspberry:

kodi, kaddressbook

good working:

all further elements of 'Kontact' and 'KDE Plasma' as well as 'phpmyadmin', 'chromium-browser' (reset to defaults), 'GIMP', 'Inkscape'

added 19/12/2018:

some more trials on an RPi B+ Rev 1.0 with 512MB RAM Released: Q3 2014 Manfacturer: Sony"
- raspbian stretch 4.14.79+
- Sandisk Ultra 16GB
- gpu 128 (so available ram 370)
- 1000Mhz
- disable #dtoverlay=vc4-kms-v3d in /boot/confg.txt
- create a directory swapspace to enable such a mountpoint
- create an ext4 partition named 'swapspace' 1GiB that is being mounted by fstab.
- modify /etc/dphys-swapfile to following settings:

#CONF_SWAPSIZE=1024 must be commented out
this sets size to computed value, this times RAM size, dynamically adapts,
guarantees that there is enough swap without wasting disk space on excess
make sure that (available ram) x swapfactor < maxswap

acceptable (but non-olympic) speed with chromium browser (Version 65.0.3325.181 + rpi-chromium-mods) and raspberry wlan-stick.
possibly your problems are caused by the memory stick or power supply.
consider a fresh install on a new fast stick, study the logs and solve all bugs , disable all unneeded system controlled services and chrome-extensions. This amendment has been edited online in chromium on the old Raspi RPi B+ , just to proof that it is not too weak to run chromium-browser

success and cheers!


Chromium is optimized for performance in complex web applications, at the expense of RAM consumption. With only 360MB of available RAM, your problem is almost certainly that Chromium needs more, and pretty much any browser will work better. You certainly don't need Chromium if you want to download an app now and then, or google / read something.

Firefox should be an option if you limit yourself to a couple of tabs, and if you still find it too slow, get a more lightweight browser like Midori. If you happen to access your RPi via SSH most of the time, see if you can get used to a text-based browser like lynx.


Simple answer: The RPi Zero is too weak to run the combination of software you mention.

It is able to run kerberos.io alone, but you will be better off buying a RPi 3 if you intend to run Chromium along kerberos.io.

  • 1
    Yo did not read well my question. As an introduction I said "I wanted to install..." The main problem is with Chromium alone. I don't need it regularly. This PiZ is used only via ssh but exceprions like Teamviewer I couldn't install from terminal. I am going to delete that part of the question to only keep Chromium issue.
    – dstonek
    Feb 8, 2018 at 14:51
  • And it doesn't make sense 100% resources with top output. Maybe the right answer would be "Chromium is unusable in RPi Z"
    – dstonek
    Feb 8, 2018 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.