1

I'm trying to redirect HDMI output of my Raspberry over ethernet to place a monitor 25m away from raspberry. I'm using a "Techly" HDMI extender like this.

My connection scheme is similar to this:

      /----------\                                            +----------+
      |          |  HDMI   +----+     25m    +----+   HDMI    |          |
      |  Raspb   |---------|  S |------------| R  |-----------| Monitor  |
      |          |         +----+  Ethernet  +----+ DVI Cable |          |
      \----------/                                            +----------+

S = HDMI Sender

R = HDMI Reciver

But when I turned on my Raspberry the monitor didn't show anything, so I tried a connection like this:

      /----------\           +----------+
      |          |    HDMI   |          |
      |  Raspb   |-----------| Monitor  |
      |          | DVI Cable |          |
      \----------/           +----------+

With this configuration works and if I switch back to the first one, the monitor after the "Receiver" shows the correct output.

I tried also a connection with an HDMI splitter like this:

      /----------\                                                              +----------+
      |          |  HDMI   +----+     HDMI    +----+      25m    +----+   HDMI  |          |
      |  Raspb   |---------| Sp |-------------|  S |-------------| R  |---------| Monitor  |
      |          |         +----+             +----+   Ethernet  +----+   DVI   |          |
      \----------/            |                                                 +----------+
                              | D
                            H | V
                            D | I
                            M | 
                            I | C
                              | a
                              | b
                              | l
                              | e
                              |
                        +----------+
                        |          |
                        | Monitor  |
                        |          |
                        +----------+

Sp = Splitter

But it didn't work. I'm using hdmi_force_hotplug=1 option on my /boot/config.txt, I also tried changing:

  • config_hdmi_boost option in /boot/config.txt
  • HDMI cable
  • Raspberry
  • Ethernet cable
  • hdmi-safe (suggested in comments)

I also tried with a notebook and the connection worked succesfully. I think that the problem is a misconfiguration of the Raspberry that is running "Debian Jessie". What am I missing?

  • You could try to disable EDID and force a specific mode instead. Also done in config.txt. raspberrypi.org/documentation/configuration/config-txt/video.md – Janka Feb 8 '18 at 21:36
  • You are using a Cat6 or better? And please change the URL to point to the english page! – MatsK Feb 9 '18 at 6:31
  • Had similar issues in the past, resolved them by setting fixed resolution in raspi-config. – pieterdp Feb 9 '18 at 18:05
  • @MatsK link fix'd – Pe46dro Feb 9 '18 at 18:38
  • @pieterdp I'm using hdmi_group=1 hdmi_mode=16 to force 1080p/60Hz – Pe46dro Feb 9 '18 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.