0

I have a local network on my island in the Stockholm archipelago. The SD-card on one of the Pi's failed so I went out and replaced with a fresh image. But I was in a hurry since the sea was starting to freeze so I only checked that I could login over ssh and left without changing anything but enabling SSH. Now I can't log in any more and I can't get to the island. Trying from another Pi on the network I get:

ssh pi@192.168.1.28
pi@192.168.1.28's password: 
Permission denied, please try again.
pi@192.168.1.28's password: 
Permission denied, please try again.
pi@192.168.1.28's password: 
Permission denied (publickey,password).

Is there any way to tickle the Pi server to behave a bit more politely?

  • Just to be clear: you can ping it from other places on the network, and its just the credentials that seem to be being rejected? Are you sure your credentials are right? – ifconfig Feb 9 '18 at 16:07
  • There is no chance by you to crack ssh. You have to know the password or use your private key (ssh knows the publickey?) or you have physical access to the raspi. Did you tried the default password raspberry? – Ingo Feb 9 '18 at 22:42
  • 1
    You're connecting to something. Do you have other user accounts on other RPis? Did you change the default pi user password? Is it possible 192.168.1.28 is a different device? It might be worth doing a portscan if you have multiple devices on the network. If it worked before you left, it should work the same later. Did you do any configuration besides defaults for ssh? – bobstro Feb 10 '18 at 2:10
  • Did you change the password? To something easily mistyped? – Thorbjørn Ravn Andersen Feb 11 at 0:26
1

Clearly you are connecting to something that has ssh enabled - it could be:

  • you are using the wrong ip address for the remote pi
  • you changed the password when you set up ssh and forgot you changed it
  • you didn't actually connect it to the network and/or when testing it while on the island you were in fact connecting to another device
  • Point one and point three isn't it the same? If you use a wrong ip address and there is no sshd you don't get an answer. – Ingo Feb 9 '18 at 22:56
1

There is no way of 'tickling' a Raspberry Pi remotely to behave differently on the SSH port (if you have no physical access to the device + SD card + network at the moment).

If you are 100% certain that the IP address you mention belongs to the device in question (assuming that you recognize the Ethernet MAC address from NMAP and know it to belong to that device), and you're using a standard (Rasbpian?) OS image + you did nothing more than just enabling SSH in the OS, then kind of the only remaining option is that you're mistyping the default password (which, admittedly, would also be odd).

Are you using DHCP on the LAN to auto-assign IP addresses? A decent next step could be to assign (in the router) a fixed IP address to the device - most routers enable you to do this. Then try again to SSH to the assigned IP and see if the default password works.

protected by goldilocks Feb 11 at 13:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.