0

I've been strugling with this problem for quite some time now, and i'm at my wit's end. I don't even have any idea what i could try to be looking for.

I have a raspi running with raspbian lite and lighttpd in my home LAN.

IP is obtained automatically and is currently at 192.168.1.3 I can connect to it per laptop (win10) and two desktop PCs (win7 & 10) with no problem at all.

The problem is, when i try to connect via my phone (Chrome on Samsung GS7E, Android 7.0, same result with "Samsung Internet"), i can not connect most of the time (though not always. there are days where i can connect without a problem...). The Browser says

This site can't be reached. http://192.168.1.3/ is unreachable. ERR_ADDRESS_UNREACHABLE

I have tried everything i can to find out why. restarted router/raspi numerous times, tried removing other devices from the network, different browsers on my phone. i tried remote debugging to see if there is any kind of information in the network tab, but i can't find ANYTHING and it makes absolutely no sense to me... Windows: works, Android: doesn't work.

I can also connect over PuTTy from windows. JuiceSSH over Android: no Route to Host

They are 100% on the same network, IP:port is 100% correct.

What are possible reasons for this behavior? how can it even exist in the first place? and how can i repair it? what are options/places i can check to see why this happens??

EDIT

ifconfig @ raspi https://i.imgur.com/TftTdHr.png

LAN devices overview @ router (Alice Box 6641) https://i.imgur.com/WYq2k2i.png

WIFI devices @ router https://i.imgur.com/EjAoNEA.png (1.5 = Laptop (working), 1.6 = Android (not working))

please note: i have LAN AND WIFI activated on the raspi. LAN is automatic IP, WIFI is static at .1.244 neither of those are accessible from android. both are from laptop

  • Your question is lacking info, example IP adr. of PC, Android. And include all network details like, IP adr., subnetmask and gateway. – MatsK Feb 11 '18 at 14:21
  • i have added some screenshots, please feel free to ask if you need more specific info – devman Feb 11 '18 at 14:41
  • 2
    Adding pictures is counter productive, when the same can be pasted in as text! – MatsK Feb 11 '18 at 17:26
  • What I understand with your infos: the raspi has ethernet and wifi enabled. Windows can reach raspi through ethernet and wifi. Smartphone cannot reach ethernet and wifi on raspi. Is there a LAN cable between Windows PC and raspi? Smartphone has no ethernet connection, right? It can only connect through wifi. Seems there is a problem with primary network device and routing on raspi. Suggest for testing to turn off ethernet on raspi. – Ingo Feb 11 '18 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.