I can successfully stream using

raspivid -o - -t 0 -w 640 -h 480 -fps 30 |cvlc -vvv stream:///dev/stdin --sout '#standard{access=http,mux=ts,dst=:8160}' :demux=h264

and I can view the stream in VLC using http://[RPI_IP]:8160 from my Windows 10 PC at home.

I'd like this to use the school's Wifi. Which is really locked down. I got the Rpi onto the school network. I can ssh out from the Rpi to my Linux workstation but all ports going to Wifi connections are blocked. I can reverse tunnel from the Rpi to the Linux PC for a SSH connection back to the RPi.

ssh -R 2200:localhost:22 -R 8160:localhost:8160 USER@HOSTNAME

The Linux PC connects fine with

ssh -p 2200 pi@localhost

The problem is VLC can not connect to http://localhost:8160

The debugging output says the packets are forwarded but the connection was refused on port 8160. I'd tried various combinations of -g,-t,-X, and adding the *: to the tunneling parameters. I even tried moving the -R parameter for 8160 to the ssh connection back to the Rpi via the 2200 tunnel.

I feel like it may have to do with the way I pipe raspivid to cvlc. That command was modified from other posts here. I'm not clear if the --sout part needs to be tweaked.

This was a lesson in how finicky the RPi0 camera cable and connector can be. I tried raspistill and got a no camera error. The tiny cable that comes with the red and white official Rpi0 case came loose during transport on both of my bots. I had to mess with it a bit and tape the cable on the camera module side to stay perfectly straight. The reverse tunneling works now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.