1

I am trying to connect to a 4G LTE network using Huawei E3372 modem. ifconig shows a wwan0 interface when the modem is connected. This is what it looks like:

wwan0     Link encap:Ethernet  HWaddr 46:b7:f0:cb:22:c2
          inet6 addr: fe80::d47d:591e:63c:8136/64 Scope:Link
          UP BROADCAST RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:8057 (7.8 KiB)

And lsusb gives me this:

pi@raspberrypi:~ $ lsusb
Bus 001 Device 005: ID 1a2c:2c27 China Resource Semico Co., Ltd
Bus 001 Device 006: ID 12d1:157c Huawei Technologies Co., Ltd.
Bus 001 Device 004: ID 10c4:8103 Cygnal Integrated Products, Inc.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However , I am not able to connect to the internet using this , I tried wvdial and sakis3g but they failed. How do I find the port of this device? How do I configure the APN? Please Help.

  • Someone on Amazon reports using a Huawei USB modem with a Raspberry Pi, but could not do it via the wwan interface until he/she used qmi-network. Unfortunately there's not a lot of documentation about that online, but it does have a texinfo manual if you install the package (see the end of man qmi-network about that...info based docs are a bit awkward...). – goldilocks Feb 16 '18 at 15:26
  • Hey when I run this command sudo qmi-network /dev/cdc-wdm0 start I get this: root@raspberrypi:/home/pi# sudo qmi-network /dev/cdc-wdm0 start Loading profile... APN: airtelgprs.com Starting network with 'qmicli -d /dev/cdc-wdm0 --wds-start-network=airtelgprs.com --client-no-release-cid'... error: couldn't create client for the 'wds' service: CID allocation failed in the CTL client: Transaction timed out error: network start failed, client not allocated – shyam Feb 16 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.