0

I'm trying to connect a ZFM-60 fingerprint scanner (https://aliexpress.com/item/Free-Shipping-USB-Fingerprint-Sensor-Support-Android-Windows-System-Optical-Fingerprint-Reader-Sensor/32475559052.html?spm=a2g0s.9042311.0.0.WVL3G4) to my RPi 3B. I'm not using the USB-serial converter, because I read that 5V output is enough for this sensor.

I followed this tutorial (https://tutorials-raspberrypi.com/how-to-use-raspberry-pi-fingerprint-sensor-authentication/) to install a library and connect the sensor. Also looked at this question (Unable to integrate Fingerprint sensor in Raspberry Pi2) changing the tty-USB0 into tty-AMA0.

When I run one of the example Python scripts, nothing happens, and the console just shows a blank line until I stop executing the Python script.

The sensor is connected as follows

  • Red -> 5 volt (pin 2)
  • Black -> ground (pin 6)
  • White -> TXD (pin 8)
  • Green -> RXD (pin 10)

Also tried switching white and green, but no effect.

Any ideas on what I'm missing here?

  • 1
    The Pi's GPIO are 3V3 safe only. Feeding 5V into a Pi GPIO will eventually destroy the GPIO and the Pi. – joan Feb 16 '18 at 16:24
  • Could you explain then why the GPIO layout mentions some pins with '5V' while this is actually not true? – ericrijn Feb 19 '18 at 8:46
  • No, and is there any reason I should? There is an awful lot of incorrect information on the www. Some just mistakes, some malicious. – joan Feb 19 '18 at 10:45
1

From the information on the page you should put 3.3v into pin 3, Vin, according to the lower table. There is a problem in that they seem to have multiple definitions of the pins of the device. The demonstration in the video shows it connected to an Arduino UNO rather than a Raspberry Pi.

The translations on AliExpress are not always exact English, and I suspect they are written by people with no knowledge of the subject matter.

To communicate the values from the Raspberry Pi to your computer I would use the built-in wireless (you said you're using a Raspberry Pi 3B).

Have fun!

0

maybe a little late, but are you using a raspberry pi 3? the pi3 has the gpio serial port named /dev/ttyS0, so instead of using /dev/ttyAMA0 you better use ttyS0, or the new /dev/serial0, the latest firmware asign the correct port (AMA0 on a pi1/2 or S0 on a pi3) to serial0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.