0

This is the price I pay for being greedy,

While working through the book exploring raspberry pi by Derek Malloy (an excellent book for understanding embedded Linux),

When I append

bcm2835.vc_i2c_override=1 to /boot/cmdline.txt using

sudo sh -c "echo bcm2835.vc_i2c_override=1 > /boot/cmdline.txt" 

and append

dtparam=i2c_vc=on to /boot/config.txt using

sudo sh -c "echo dtparam=i2c_vc=on > /boot/config.txt"

my RPI3 crashes upon reboot, meaning it goes into panic mode and none of the cores load.

reinstalling raspbian lite from debug fixes the problem short of being able to enable i2c-0, the i2c device used for RPI HATs.

uname -a tells me that I'm using 4.9.59-v7, I later tried this on 4.14.18-v7 resulting in the same behavior.

the i2c-1 device was/is available in /dev, I manually enabled this prior to attempting to enable i2c-0.

/boot/config.txt has dtparam=i2c_vc=on and dtparam=i2c_arm=on

/etc/modules contained i2c-dev and i2c-bcm2835

Any help or suggestions would be greatly appreciated.

0

I2C bus 0 is not available for use on the Pi3B. It is used internally.

See https://www.raspberrypi.org/forums/viewtopic.php?f=44&t=138897&p=923243

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.