2

I have an application which needs Mono 5 to start properly, since my current version (4.6.2.7+dfsg-1) does not work with it. Also 4.6.2.7+dfsg-1 seems to be the only version I can get installed. Can somebody help me out with simple commands to install it easily, which are confirmed working? Also do I need to remove the current mono version, if so: How?

Using a fresh installed Raspbian Stretch Lite, updated and upgraded.

I also did some googling, went through some tutorials and still am sitting with the same Mono version. Things don't seem to work that easy, also I am pretty new to all of this. I know the basics though, but this is something way more advanced to me. The most promising tutorial was this one: http://www.mono-project.com/download/stable/#download-lin-raspbian But it didn't end up with getting the Mono 5 version, still got the 4.6.2.7+dfsg-1 version. (Didn't encounter any errors >installing< it here though.)

Also how do I correctly uninstall the current Mono version I have?

Thanks a lot

Edit: I just started over recently and just installed it freshly. Was some manual work needed to manually edit the package source but in the end the above linked tutorial then did the trick.

1

You do need to follow the instructions at: Mono - Download

The problem is that they are missing a step. Those steps will only upgrade our repo list so that it will find the right version of mono to install, but they do not install it or upgrade an existing installation.

If you want to upgrade an existing installation, you need to follow up with:

sudo apt-get install --only-upgrade mono-complete

If you are installing for the first time, leave off --only-upgrade.

0

I experienced the same problem using the same guide. Installing mono-complete allowed me to upgrade to 5.12.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.