2

This question was asked out of mostly curiosity.

I've just flashed a new SD card with Rasbian Stretch Lite and when I did, little did I know that Stretch Lite is very similar to Arch Linux Arm. And Arch Linux is all about being as minimal as possible.

So then, I found myself having a very long line of package installations. Too bad that when I tried to have three Terminals running sudo apt-get install packagename at the same time Linux kept on telling me that "some other process has locked down sudo."

What? Why?

This is really just a general question: The simplified question would be as to why "you can't have more than one root terminal process running at once?" Think installing multiple software packages, like I tried to do.

  • 1
    no problems running sudo on multiple "terminals" - are you sure the error isn't regarding apt-get? because that can only have one instance in most cases – Jaromanda X Feb 19 '18 at 2:29
  • @JaromandaX This just really a general question. That software installation problem was just an example – iostreamerX Feb 20 '18 at 1:52
  • 1
    that software installation problem is because you can only have one instance of apt-get running ... there is no limit to how many sudo are in effect at any time - so, the question is flawed – Jaromanda X Feb 20 '18 at 1:58
2

You can have as many root terminals as you like. I'm pretty sure the actual error message you saw is not what you've put in the question.

What you can't do is running several instances of apt running in parallel on the same installation. apt keeps information in several files which have to be updated coherently, so the first instance you run will create a lockfile preventing subsequent instances from running.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.