1

I cant find the answer, How can I disable requiring password to mount Flash drive, Just plug USB and open folder without password.

enter image description here

  • Have you tired to plug this drive in another computer? It require the password? – Francesco Gusmeroli Feb 20 '18 at 11:01
  • raspberry (raspbian) require password NOT flash drive. I tried several pendrives and SD - card and the same thing every time. – Scan π Feb 20 '18 at 11:45
  • you change something in user settings?you are logged with pi user or not? – Francesco Gusmeroli Feb 20 '18 at 16:18
  • i'm logged with pi user via HDMI to TV and via VNC-server. in both cases the same problem Only from the root level does not ask for a password. I'v tried youtube.com/watch?v=ByTx6U-HcbE – Scan π Feb 20 '18 at 16:52
1

Sounds like pmount could be your new buddy.

pmount is a wrapper around the standard mount program which permits normal users to mount removable devices without a matching /etc/fstab entry.

Debian -- Details of package pmount in stretch

to install: sudo apt-get update; sudo apt-get install pmount

0

I have updated RPI to a newest version and now this error is no longer occurs with the connected device via HDMI (PI user does not require password authorization). But still requires password authorization when connecting via the VNC-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.