1

I'm trying to use realtek 8188cu module in concurrent mode(both station and AP mode simultaneously). I downloaded the driver source files from here: https://github.com/raspberrypi/linux/tree/204050d0eafb565b68abf512710036c10ef1bd23/drivers/net/wireless/realtek/rtl8192cu

And I modified the include/autoconf.h: enabled the commented out line: #define CONFIG_CONCURRENT_MODE 1

i'm running the latest stable release for raspbian lite: 4.9.59-v7+ I downloaded the linux kernel files by running rpi-source --skip-gcc

And I built the kernel module using the command: make -C /lib/modules/$(uname -r )/build M=$(pwd) modules The compilation succeeded without giving me any errors, but upon inspecting the 8192cu.ko file generated after compilation, I find out that its compiled to the wrong kernel version. Below is the vermagic information when I ran modinfo ./8192cu.ko: vermagic: 4.9.58-v7+ SMP mod_unload modversions ARMv7 p2v8

Tried modprobing the .ko file. Did not work.

But I don't even have kernel sources for 4.9.58-v7+.. What is going on? Can somebody help me to compile the driver successfully and to get it working with latest raspbian stable release?

Thanks

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

I don't even have kernel sources for 4.9.58-v7+..

The source tree is on github: https://github.com/raspberrypi/linux

However, there are only branches for each minor version, and the current sublevel if you look in the Makefile for 4.9.y is 4.9.80.

If you look at the history of the Makefile, though, you'll find the commit from upstream for 4.9.59 was October 27 last year. The closest release from the Rpi tree is October 29, and if you download that it is indeed 4.9.59.

Running make bcm2709_defconfig should give you the configuration for v7+, and if you are lucky, building a module against that will match your kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.