0

So, what I am trying to do is that I have my RPi3 and PC connected to the same LAN, and by using SSH, I can connect to the RPi3. And important thing to note is that I can connect only one of the devices (PC or RPi3) with an ethernet, the other device has to be connected via WiFi. The actions I describe below have my pc connected to the LAN via ethernet and the RPi3 with WiFi (although I tried it even the other way around).

So here I what I tried:

  • Downloaded and installed the latest raspbian.
  • Connect my RPi3 on a screen, keyboard, mouse and power supply.
  • Open bash and open raspi-config file
  • I enebale SSH, disable the graphical interface and connect to my WiFi
  • Then I type "sudo nano /etc/dhcpcd.conf" and add the following text in the top (to have a static IP):
interface wlan0
static address 192.168.1.100
static netmask 255.255.255.0
static gateway 192.168.1.1
  • Then I reboot my RPi3
  • It now open in the bash. I type "ifconfig" and there is shows that my wlan0 IP is 192.168.1.100
  • I shut down my RPi3, take out the HDMI, mouse and keybaord, and power it up again.
  • Then from my PC, having already installed, on my windows 10, PuTTY, I give the IP address, and wait. After a bit I get this message: enter image description here

I have tried to connect the RPi3 via ethernet (canging the wlan0 in the dhcpcd.conf file) and use the wifi on my pc, but got the same problem. Any tutorial I have seen, video or question on this site, has not the same exact problem. At least from what I have found, they have some problems after connecting. But I can't even connect, at the first place

Is this because i am using WiFi or am I missing something else?


P.S. I will not list all the tutorials I have seen, but here a few of them (of which some of the are with older Rasbian versions, I know):

  • 1
    Is it possible to run the Raspberry at least with a monitor connected? Perhaps any error is shown on the monitor. – Uwe Plonus Mar 2 '18 at 14:34
  • 1
    Ya, I agree with above, you can ssh into it while it still have the keyboard/mouse/ monitor, this way you can tail any logs that are relevant and also be sure that there wasnt a problem booting back up. Maybe it failed to load the static address on reboot and has another address now. – Chad G Mar 2 '18 at 17:02
  • KISS, Keep It Simple and Stupid is a good practice in troubleshooting. 1 Remove the static IP, change it to a DHCP, does it work? If not , can you connect to the wireless network? Can you connect to the wired network, and so on.... – MatsK Mar 2 '18 at 18:36
  • I took your recommendations. Removed the static IP part. Also, I confirmed that I am property connected to the wifi by pinging google and getting a response. Lastly, no errors or warnings appear at any point. So now I have screen and keyboard connected. I get my IP by typing ifcomfirm, and put that IP in PuTTY, yet still I get the same result (no connection). Not sure what else to do. – Dimitris Pantelis Mar 3 '18 at 12:55
  • What's the IP address of your windows PC ? Are both your PC and RPI3 in the same network ? Can you, from your windows PC ping the RPI IP address ? And in the RPI3 ping the windows IP address ? – Feiticeir0 Aug 29 '18 at 15:13
1

Solved the same issue by checking the IP address in the wireless router page on windows, it was different from the wlan0 address on the Raspberry Pi

wlan0 on the Pi - 172.16.0.11
IP address on router page - 10.0.0.8


Windows > got to router (http://10.0.0.138) in address bar > Networks > Devices - and look for the Raspberry Pi IP address

Windows > PuTTY > enter the address shown on the router page

0

I don't know programming but I can follow instructions, so maybe this will help you. I run a data upload application on my RPi3B that required the Ethernet connection. I wanted to connect to the 'net on WiFi so I asked the developer how to do this. Here are the steps he provided which subsequently provided the WiFi connection and also gave me SSH capability over my WiFi. This may work or it may be useless to you:

  1. Connect via Putty (over Ethernet) & login to your Pi
  2. Run this command:

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

You should see something like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

update_config=1

network={ 

   ssid="enter your router's name here"

   psk="enter your password here" 

}

Enter your router's name in ssid and your password in psk. (The quotes are required, e.g. ssid="mynetworkname")

  1. Save and restart.

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.