2

I have about 400 pi units and some of them have developed a peculiar issue. The eth0 interface appears to be up, but I can't seem to pull a DHCP address. When I set a static IP, it shows in the ifconfig output, but the interface can't ping anything. I've looked at the dmesg output, but nothing stands out. Is there a diagnostic I can run to verify that the network interface is functioning properly?

These units are all using a POE hat module. Most of the units seem fine, but this issue has started to appear on about a dozen units so far. Any help is appreciated.

7
  • 1
    Are you sure it's your Pi and not the network? You may have run out of IP addresses to distribute. A more or less "standard" set-up at home will only have 254 addresses to give.
    – Brick
    Mar 2, 2018 at 18:02
  • I am absolutely 100% positive it's not the network. I'm a network engineer by trade, so I know my way around these things.
    – Kimomaru
    Mar 2, 2018 at 18:04
  • RPi does not support POE by default, what hat module do you use? RPi 3 b? OS? Same issues without POE?
    – Fabian
    Mar 2, 2018 at 18:07
  • 1
    You could also try Wireshark to see what (if any) messages are going onto the network. You could run this a misbehaving Pi and on a working one to see to what extent they match.
    – Brick
    Mar 2, 2018 at 18:11
  • @Fabian , I am using the Pi PoE Switch HAT module. Seems to work great, not sure if the issue I'm working on is related to it at all.
    – Kimomaru
    Mar 2, 2018 at 18:20

2 Answers 2

1

Michelangelo was asked how he could so accurately represent the human form in his sculptures. He responded that he didn't sculpt the figures, he removed the stone to reveal the figures. That sometimes is the only way of troubleshooting complex faults: through a process of exclusion- what remains is the problem...

  1. Test the connectivity of the Pi's not catching a DHCP address without the POE hat. This will either isolate the fault down to the POE hat, or exclude it as a potential cause. Didn't see you test for the hat being the potentially causal of the fault.

  2. Try the hat from the affected Pi on another Pi known to work correctly. If that Pi now errors in the same way...

  3. For the sake of completeness, try testing the affected Pis connected to a different port to prove there's no Layer 1 issues at the switch port. If the affected Pi doesn't catch an address where another one was, can exclude the fault being related to a dodgy port.

  4. Again, for the sake of completeness, I'd try testing the affected Pi with a different cable known to work correctly with another Pi that is catching an address.

  5. Compare OS & Kernel versions of Pi's known to work correctly with one's not catching an address: lsb_release -a and uname -r

  6. As a rule, I generally knock any dynamic network configuration crap like NetworkManager on the head. Can introduce variability

  7. Power fluctuations will puke errors in dmesg- which you reviewed- so if the POE was flaky, I'm guessing you'd have seen evidence on the pi itself. Again, for sake of completeness, review the POE switches for correctness to exclude them as introducing any flakiness. I'm guessing you looked for snakes under that rock already though

  8. @Brick already suggested Wireshark...

Maybe by removing what is not the fault, like Michelangelo you'll reveal what's left: the fault. Anyhoo, just some ideas to help you get unstuck with this issue bud. Must admit, I'd be curious to know how things broke for my own edification. HTH- Terrence

1

I had a similar problem a while back. How are you setting the "static IP" for the Pis? If you're setting it up within the Pi using /etc/dhcpcd.conf, it may not be negotiating this with the DHCP server, and may just be assuming that the IP is available. This is the problem I was having.

I stopped setting up the static IP with the Pi and set it up on my router instead.

Could you please explain how you set the static IP to clarify whether or not this could be the problem?

EDIT: Sorry I didn't see how old this thread was, has your question been resolved? If it has it is worth marking it as answered so you don't keep getting answers.

2
  • But what is the answer that solved the problem?
    – Ingo
    Mar 19, 2019 at 13:36
  • @Ingo I stopped setting up the static IP with the Pi and set it up on my router instead. Apr 9, 2019 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.