3

I reinstalled my Raspberry Pi with the latest Raspbian wheezy (2013-05-25-wheezy-raspbian) and modified the console keyboard with raspi-config to match my AZERTY setup. The layout is now OK on the console.

It is still QWERTY on the GUI, though. I tried to find the relevant entry in the menus but I just found how to set speed, sensitivity, etc. - but not the localization.

What is the proper way to set up and AZERTY keyboard on the GUI?

Thanks!

2

My Pi is running headless, so I can't test this, but first have a look at this page. Then try if you can set the keymap from a terminal:

setxkbmap fr

This should switch to french azerty layout. You can put this command into your ~/.xinitrc if it works. There are also many other keyboard layouts available (like be for Belgian azerty).

Edit: If you want to make this permanent, you need to make sure the ~/.xinitrc still starts the default WM and desktop. So put these lines into your ~/.xinitrc, if it does not exist yet:

setxkbmap fr
. /etc/X11/xinit/xinitrc

This will run the default xinit script after setting up the keyboard layout.

  • Does this permanently work or is it just temporary? In the case of the latter, how could we make it permanent? – Matthew Moisen Jun 25 '13 at 17:09
  • If you add it to your ~/.xinitrc, you can make it permanent. – Arne Jun 25 '13 at 19:08
  • Added another paragraph to my answer, to clarify. – Arne Jun 25 '13 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.