0

Here is the case:

  • I have a notebook and a Raspberry Pi on a local network
  • I want to start omxplayer from the notebook to run on the Raspberry PI showing video there but playing the sound on my notebook.
  • paprefs is set on the notebook to
    • “Enable network access to local sound devices”
    • “Allow other machines on the LAN to discover local sound devices”
    • “Don’t require authentication”
  • paprefs is set on the PI to
    • Make discoverable PulseAudio network sound devices available locally
  • padevchooser on the PI finds the sound server on the laptop

Now On the PI I run omxplayer -o alsa video.avi, it plays the video on the PI and plays the audio on the laptop. It seem OK.

BUT.

  • From the laptop I login into the PI
  • I run the omxplayer -o alsa video.avi

Result: An error message appears:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection terminated

and no audio either video is played

Remark: in case of omxplayer -o local video.avi it plays the audio and video on the PI

What would be the problem here?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.